Graphics issues with new update

Installed the 23 Nov 2020 update and my screen has some issues. Running Windows 7

Same issue, after latest update 24/11 in Australia, graphics have gone all black and blue. Had no issue prior to update. Graphics driver all up to date.

Same thing big black square in middle of screen and the rest is flickering like crazy.

Windows 7 is no longer a supported OS by Microsoft.

There is also too little info to better assist you on your issue: Guide to Getting Useful Support

2 Likes

I have the exact same issue. I have windows 7 too.
What does this mean?
Do I have to buy a new laptop?

It was working perfectly two days ago and now I need to go and spend hundreds of pounds because of an update?

Jim

2 Likes

You could try uninstalling Zwift and re-installing it.

Thanks Paul, I have just done that. It took ages and unfortunately it is exactly the same.
My computer has never had a problem like this with Zwift. It meets the minimum system requirements as far as I am aware.
What other information would be needed to help diagnose what is going on here?
thanks,
Jim

Post the specs of your PC so we can see if there is a common thread.

It could be a Win7 issue, but I’m not sure.

Same problem. Windows 7. After the last update graphic is black in the center of the screen. Help please.

I am starting to think Win7 is no longer supported for Zwift.

I am trying to get some clarification on it.

Processor: Intel® Core™ i7-2620M CPU @2.70GHz 2.70GHz
Installed memory (RAM) : 4.00 GB
System Type: 64-bit Operating System

Its on Windows 7.

is this enough information?

1 Like

Yep big black square in the middle. I wonder if they will do anything about this. Really don’t want to buy another lap top at this stage and my Android is unreliable. :-1:t3:. Not impressed at all.

What system do you have?

Try to uninstall Zwift and Star from scratch.

I have a laptop Sony with win 7 and with two integrated video cards. Switched by a mechanical switch. Before the update there were no problems, after the update on a weak video (Ati radeon) card frames, on the other (nVidia) it works (checked on the splash screen). On another PC with win 7, where the video card is more powerfull, also works. Zwift totally reinstall. Trouble not in Win 7, but something with grafics.

Having the same issue. Also running Windows 7. I uninstalled and reinstalled zwift, updated my display drivers, nothing helped

See if you can upgrade to windows 10