Gradient of 1% suddenly feels like 5% on Direto


(wai loon) #21

Some pointers I got from Zwift Customer Experience Agent which you may find relevant:

===========================================================================
Some users have tried these steps and claim it works (but they have to do it each time):

  1. Unpair your smart trainer from the Paired Devices Screen (Power Source, Controllable, Cadence)
  2. Power off (unplug) smart trainer.
  3. Leave unplugged for 2 minutes.
  4. Then turn it back on.
  5. Pair your smart trainer to Zwift under Power Source, Controllable, and/or Cadence.
  6. Continue your ride and see if resistance re-engages.

If you’re continuing to have problems with ERG mode or resistance in SIM mode rides, put those steps into practice and please let me know if it helps.

  • Also, have you tried turning off native (built-in) Bluetooth on your Mac​ and then pairing your trainer to Zwift using the Zwift Companion? If not, maybe give that a try and see if it helps. We’ve written a guide for connecting via BLE on our knowledge base?
  • Alternatively, you can also use ANT+ as a means of pairing your Kickr to Zwift if you have an ANT+ Dongle and USB 2.0 Extension cord​. Since this issue has been identified as being a problem primarily with Bluetooth pairings, you may want to consider trying ANT+ as an alternative pairing method.
  • Check the Elite app for any firmware updates and if there are any available, please download and install the latest firmware.

===========================================================================
Hope it helps!


(Peter Castrop) #22

Before I tried Zwifting on my Android phone yesterday I tried the Ipad, using Bluetooth as I used to do before the problem started. I hoped the update would have solved the problem. The strange thing is that when I am riding on the small ring in the front it seems fine. But when I change gears and switch to the big ring in front the gradients are not right and 0% feels like climbing. I have tried all the suggestions. Using Ipad, Iphone and Macbook, and Windows laptop. Unpairing and pairing again. External cadence sensor. Also paired with Bluetooth and with ANT+. I always unplug the Direto after each ride.

What is the difference between the Android app and the IOS app regarding the connection?


(Kenneth Vib����Aek) #23

Acer laptop with Windows 10 64-bit


(Ian Cartwright Race3R) #24

Following this thread with interest. I’m having the same problem with my Direto and it was NOT solved by the latest Zwift update.


(Peter Castrop) #25

Is it possible to get the version of Zwift before the last 2 updates? On IOS that would be version 1.0.28834.


(Matz Binder) #26

I have had similar issues with my Direto which where - in my case - related to a miscalibration of the Direto. The Elite support highly recommended to tension the belt up to the exact offset value you can find on the sticker underneath the trainer.

You may double check the calibration and if needed tension the belt. The proper calibration solved my issues.

Cheers, Matz


(Peter Castrop) #27

Today I received this email from Elite:

Good Afternoon

The problem is not caused by the trainer or Elite but from how Zwift has implemented the standard Bluetooth FTMS protocol
So if they have made some mistake obviously the issue is not from our side but from them

Please refer directly to them


(Peter Castrop) #28

Hello people at Zwift. Any news, progress, activities, communication on this matter?


(J Iri) #29

Had a first ride at NYC course and the problem is still there. Since this is a rolling course, staying with the group in the race was a real challenge.


(Peter Castrop) #30

Hi Vincent, any news or progress?


(Peter Castrop) #31

Guess not :confused::frowning:


(Paul Bryan) #32

My first ride of the NY course revealed this issue for me as well. Without changing the trainer difficulty, my climb up the alpe the previous day was infinitely easier than my first ride of NY. In NY I am now using gears that I had not even touched to climb up the 10-15% gradients in watopia. Funny thing is that trainer seems to be reacting a little quicker in relation to the terrain change, which is actually a good thing. The problem is that it seems to go from flat to climbing a wall. I’ll be playing with Bluetooth and firmware updates now that I know this is a known issue.


(Vincent W.) #33

@Paul_Bryan @Peter_Castrop
Are you all still experiencing these resistance issues? We’ve made significant progress in resistance trouble with BLE connections as pointed out here:


(Peter Castrop) #34

Hi Vincent,

Thank you for your message. I will try this tomorrow. Normally I would plug in my trainer and then open the Zwift app on the Ipad. I immediately get on my bike and pair the trainer and the hr. I normally do not walk out of range.

I will let you know if the problem still exists.

Peter


(J Iri) #35

Looking forward to get this fix going. I will be smashing everyone in races due to artificially increase resistance in past months. My point: my Direto is never out of reach. All devices are plugged and unplugged before and after each session…


(Clayton Bigsby) #36

Just found this Direto specific thread…have been posting on another
here:

then tried the above suggestion to reset…

FYI ://

This is either something Zwift DID or Apple DID


(Peter Castrop) #37

Hi Vincent,

The update has not changed anything for me. I still have the same resistance issues.

Kind regards,

Peter


(Clayton Bigsby) #38

Well…I disconnected and then reconnected EVERYTHING…AGAIN… re calibrated my Directo after proper warm up…and adjusted the belt tension back to factory spec.6458… it had loosened 6 pts…in about 7-800 miles of riding.

The NEW UPDATED 1.0.31664 for my hardwired Imac loaded at start up and I did a test ride on Volcano loop…also used companion app on ipad pro as always…Realism set to 100% as always…
and it SEEMED to be acting “normal” again…

I need to ride NYC today and see if it is still good there…THAT is where the problems were 1st noticed and made my Direto unridable…

Hopeful…


(Peter Castrop) #39

Well, Zwift seems to have no interest in solving this issue. They are busy unlocking socks and sunglasses.