Gradient of 1% suddenly feels like 5% on Direto


(Peter Castrop) #1

For two weeks now I have an issue with my Direto. Gradients seem a lot bigger and even at 0% gradient it seems like I have to push harder than before.

I use my Direto on an ipad pairing through Bluetooth.

Please help because racing is no fun anymore.


(Vincent W.) #2

Sorry to hear that Peter! Have you tried lowering your trainer difficulty?
There also may be a slight issue with your BLE connection, which you can troubleshoot with this link: https://support.zwift.com/en_us/my-bluetooth-signal-is-dropping-running--BJkESEzU7


(Peter Castrop) #3

The trainer difficulty always was at 50%. I didn’t change it but suddenly a 1% percent gradient feels like a 5% one. I don’t have any other equipment near or between the trainer and my ipad. I didn’t change the setup.


Unexpected power/resistance fluctuations in SIM mode
(Karl F) #4

Hey there Zwift. Another Direto user here with similar problems. In the old forum there were MANY reports of similar problems with the Direto trainers. Is Zwift saying that all Direto problems are due to BT connection? This seems a bit of a stretch quite frankly.

Is the Direto resistance problem now closed by Zwift?

Thanks


(Luc Heijnen) #5

Another Direto user. I had the same problems, turned out to be an older version of bluetooth on macbook/ipad vs the Direto. Only the iPhone 7plus would pair in my place. I bought an ANT+ dongle for the macbook: works like a charm!

Also, un-pairing and re-pairing was the solution after resistance troubles (for some reason after a random Zwift software update), but then again using the ANT+ connection.


(Peter Castrop) #6

Thanks for the suggestion. I will definitely try this.


(Vincent W.) #7

Yes, it is a BLE issue with Diretos specifically. Our QA team is looking into this. :slight_smile:
In the meantime, I would advise trying out Luc’s tips to see if the help in any way.


(Peter Castrop) #8

I really want this to be solved so I bought an ANT+ adapter. I did a race on Zwift yesterday, but the ANT+ connection made no difference. Still the same problem (and 34 euros down the drain). I used a Windows laptop yesterday. The problem exists on IOS, OSX and Windows.


(J Iri) #9

Hi, same issue as Peter. There is bunch of people reporting this issue in Direto Facebook group. This has been going on for at least 2 weeks. Tried calibration, repairing, checked difficulty. Using Direto via BLE to Apple TV.


(Peter Castrop) #10

Tried an external cadence sensor today with ANT. The problem remains. I am out of options now. I think I will stop my Zwift subscription until they solve it.


(Nicolas Berger ) #11

Ant+, BLE, external cadence sensor, new calibration, etc… Nothing works.
Even with trainer difficulty at 0 (lowest) I have variations resistance… Please, find a solution :slight_smile:


(wai loon) #12

Was facing similar problems with Direto pairing with Macbook via BLE/Bluetooth.
Switching to ANT+ connection solves the problem for me.


(Peter Castrop) #13

Lucky you! I wish I could say the same.


(Danny Boyd) #14

have any of you guys actually spoken to ELITE?


(Peter Castrop) #15

Yes, I have. I have done a test as requested by Elite using the E training app from Elite. The answer from Elite is that, based on the log file I sent them, my Direto is working properly.


(Peter Castrop) #16

Today I managed to download the beta Zwift app on my Samsung phone. I thought I would give that a try. And surprise: the Elite Direto worked as it should. The gradients feel normal again. I am so happy that for now I have found a way to Zwift again. My only hope is that there won’t be an update that ruins it all :slight_smile:
And I hope Zwift fixes the problem, because my screen on the phone is very small. I totally missed the sprint this evening because I couldn’t read how far it was to the finish!


(Vincent W.) #17

According to our latest update, Direto resistance issues should be significantly reduced. If you all get a chance to try it out please reply here! :slight_smile:


(Kenneth Vib����Aek) #18

I have tried it now and there is not a significant change :frowning:


(Vincent W.) #19

Which device were you Zwifting with?


(Michael Borski) #20

I have same issue. What I have done is given 300% force for 4-5 seconds and direto then behaves, feeling the proper resistance