Garmin HRM no signal [SOLVED]

My issue was no HR on Zwift when running it on my iPad where I also had the Garmin connect app. I deleted Garmin connect and HR on Zwift been fine since then.

Same issue. My Garmin Dual HRM just quit working with Zwift last night after working flawlessly for a long time. Nothing changed about my set up. The HRM works with all other apps and devices which of course are turned off when trying to use Zwift. Is a factory reset of my iPhone really the only fix for this problem? Frankly, I’d rather just buy a new HRM, or use Trainer Road instead.

Appreciate your post. Helps us newbies navigate through the maze!

I’m newbie with iPhone 11 Pro - your data is consistent with what I’m seeing. Connecting but no dat for Dual HRM. Thanks for post!

Same issue here, although it’s not strictly Zwift with issues. Any app on my iPhone 12 won’t receive HR data even though it is connected (strava, wahoo). Still working fine on my edge 830.

Rang Garmin support, they’re aware of the issue and HRM is being replaced under warranty.

I have had the same issues as others have noted on here.
I borrowed a friend’s Wahoo Tickr HRM and it worked straightaway on my Zwift ride. They are quite well priced so have ordered one and will use the Tickr HRM when using Zwift and the Garmin HRM when riding outdoors!
The Garmin Dual HRM works great with my Garmin 530.
Not a perfect solution, but needed to get heart rate showing on Zwift ahead of races in the Autumn and Winter!

Fixed….very easily. Get a Wahoo Tickr……
My Garmin dual was not displaying H/R on both IPad and IPhone……whilst using at least 5 or 6 different Apps.
HRMDual could be found ….but didn’t display any data.
I believe it is a Bluetooth issue with the devices……not the apps themselves.
Bought a Wahoo Tickr……it can Bluetooth up to 3 different sources at once………all apps have NOT missed a beat since.

I will use my HRMDual with Garmin devices for other training.

1 Like

I’m having the same problem.

I just started having this issue after I udpated zwift yesterday for the newer version.
Any one knows if its an application issue- as my strap is working and brand new i see the blue tooth on the my garmin head unit and my PC as well they show perfect battery at 85%

I ordered a new Wahoo Tickr and the new oneworked instantly too. It is good to see the heart rate displayed on screen and of course essential for racing!

I’ve been having issues with No Signal when connecting to my HRM-Dual recently since I’ve stopped pairing via the Companion App, and my last couple of rides have no heart rate data.

When I got the No Signal error when preparing to ride yesterday I decided to check that the HRM-Dual would provide heart rate to my Garmin watch. I left the HRM-Dual connected to Zwift and paired it to my Garmin, checked my heart rate then removed it again, (I use an HRM-Run for running outside).

When I returned to Zwift, the HRM-Dual was still connected and showing my heart rate. I started my ride and, apart from one 15 second dropout after approx. 9 minutes, Zwift recorded my heart rate for the entire 42 minutes of the ride. I completed another 45 minute ride this evening and no connection issues or dropouts.

I can only speculate that pairing the HRM-Dual to my Garmin has ‘reset’ the HRM-Dual in some way, (reverting something Zwift did possibly?), which has, temporarily at least, resolved the Zwift connection issue. I’d be interested to see if this works for anyone else.

Good luck.


1 Like

I don’t know whether this is mere coincidence but I did the exact same thing today. I returned to this post to see about any updates to the situation and I saw your post. So far so good :crossed_fingers:

1 Like

It is definitely an iOs problem. I have HRM Dual connected to a 6s plus, suddenly HR would not be measured anymore. It does not matter which app (strava, health, systm… you name it). I can connect my HRM with my Edge, with my PC, with my laptop and my partners iPhone 12, it even works my old iPad air on ANY app. But not on my iPhone 6s plus. Weird stuff… I am hesitating to do a factory reset. Did anyone got that problem solved WITHOUT factory reset (I tried all other stuff though…).

Somebody else used the reset option and it did not work.
I also have an iPhone 6s which works fine with HRM Dual with any app (Zwift, Rouvy, Tacx etc…) but on my other iPhone (XS model, which I wanted to use for training) stopped working after a few sessions. Somebody said that the problem is caused by the Garmin Connect app which could be true because I have the Garmin Connect installed on my XS but not on my 6s. Never bothered to deinstall and try because at the end I rather use my 6s for training so I can have the XS for chatting etc while riding.

Hi Marko, thanks for your fast reply :slight_smile:
Uninstall of Garmin connect, incl. reset of network settings and restart of iphone did not change a thing. On my partners iPhone are the same apps as on my phone… I do not want to reset my phone, too much hassle.
Any other suggestions that may help?

I’m having issue with my Garmin HR when using windows laptop (connects but states no signal) but works fine on my phone? It did work initally but cannot connect at all now! Anyone know a fix for this?

OK the hardreset, complete delete and NO restoration from backup solved the problem. I installed Garmin Connect and Strava, data from HR-sensor was received. Its a real fuss to reinstall everything, but once in a while it cleanses the phone as well… Lets see if the problem will come back.

I´m having same issue on Huawei P20 with no signal on Garmin HRM with Elite DiretoXR :confused:

I first connected the HRM Dual to Strava o iOS: worked fine. Then I used Zwift desktop on a MacBook for one session. It worked but dropped connection/ data so the graph had dips going to zero. Then I used Zwift and sensors via the companion app. It worked for 5min, no dips but now it shows Zero on every iOS app (Strava, Wahoo) and it won’t work with Zwift desktop + Companion.

Same issues! Except I use Android, no apple. I have Garmin Dual HR, used to work perfect every ride. Now HRM will connect, no problem. but then I get ‘ConnectionError!’ and ‘No Signal’ . And I run Zwift on my windows 11 (I already upgraded from 10), laptop.

The only fix that just worked for me: Uninstall Garmin Express from my PC. Uninstalled any ANT+ from my laptop that i saw in my list of apps in the control pan. (I had downloaded a utility or driver trying to fix it. :roll_eyes: so I had to uninstall those as well.

I rarely connect my Garmin to my pc, so it should be fine. My garmin has wifi so it downloads and installs its own updates when they come out. When i need to plug into my laptop, I will reinstall garmin express, but zwift is working again fine now.

Also, my zwift companion app stopped working (wouldnt launch me into the game automatically like it used to), but once i uninstalled garmin express, it is now working again fine.