Game Update 1.42 [June 2023]

That’s ok. I just didn’t know if I wanted to invest in a Sterzo but I do want to be able to some day ride ALL the roads in Watopia. Thanks for clarifying.

1 Like

You could just have left/right buttons

1 Like

Repack Rush not available on ATV this morning after updating. Teleporting is though… That is fantastic!

Anyone seeing Repack Rush on ATV?

Yes, I can see it on my ATV 4K (2021) running 1.42.0, but only if a steering device is first paired in the pairing screen.
(If you don’t have a steering device, Repack Rush will be pointless.)

BTW, I’ve experimented with un-pairing the device after having got to the ‘Explore Routes’ listing that is showing Repack Rush. This doesn’t instantaneously make Repack Rush disappear from the routes, but if I move to ‘Workouts’ and then back to ‘Explore Routes’, I can no longer see Repack Rush.


Hello Zwifters - more devices will receive the 1.42 update today.

Did you pair to a steering device before you dropped in to the Home Screen? Repack Rush won’t appear unless you did.

The game is context-aware and won’t show you options that you can’t use. Another example is the Trainer Difficulty slider - that doesn’t appear unless you’re paired to a smart trainer’s “Controllable” signal.

1 Like

I’m just wondering, in your opinion, is getting a Sterzo worth it? I just am wondering are there some flaws and do the pros overweight the cons? I would LOVE to try the new steering course!

Hi @shooj and @Jon, is there any information available on rider shadows making it to M1 Macs? I recall seeing that it was planned for after the transition to Metal which has now happened, so was hoping for some indication re: timeline.

1 Like

NYC has had the same bug for ages but it’s less extreme (in Makuri it was also there from the start but only became ridiculous with the latest expansion): Minimap magnification changes on its own

I guess this must also be “a very minor issue”.

Same “minor” issue as the delayed elevation gain in all London routes. That one bothers me even more than the giant zoom in on mini map.

I’m one of the several people who have recently re-reported a rather old bug with steering on the Kickr Bike where one gets stuck on either the left or the right edge of the lane, esp. when riding with pace partners.
Just got the 1.42 update and decided to try Repack Rush. Here’s what I saw:
Steering works well for a a minute or two (even though it’s laggy enough for the game part to be a bit frustrating), but then I got stuck on the right edge and no steering button press, hold or mash would move the bike. It does recover though! After about another minute(?), the steering buttons moved the bike again. Unfortunately shortly thereafter, I got stuck again, this time on the left edge, and nothing would get me off of it.
Seems to be very straightforward to reproduce as it happens almost immediately, but happy to help debug this further.

I didn’t pair my sterzo but will do tomorrow. Thanks

More data points in case it’s helpful:
Decided to continue in Free Ride after Repack Rush and go around via Titan’s Grove two more times. During the first round on Titan’s Grove, I was glued to the left side of the lane, and nothing would get me off. When I got back to Repack Rush, I started on the left side, then after a minute, it recovered and allowed me to steer for about 30 seconds, then I got glued to the right side.
On my second pass through Titan’s Grove, again glued to the left side, and in the third pass through Repack Rush, stayed glued to the left all along except for some randomness for 10 seconds in the middle.
The steering feature is clearly an important one in your roadmap, given all the time and effort you’re spending on Repack Rush vs. other stuff. Hope you can fix the bug that makes steering basically unusable on one of your premium hardware platforms for more than a year now!

EDIT: We’re looking at enabling shadows on M1+ Macs in the future, but don’t have a date to share on this yet.


I tried Repack Rush yesterday and it worked just fine on Kickr Bike V1. I did feel like I had to mash the buttons to get myself to move left and right, and it didn’t always happen very well the first time. I’m not sure whether I like steering working by shifting through “lanes”, but I need to think it through more :face_with_monocle:.
One minor bug… one time after Rushing I took a right turn toward the desert, and for a few hundred feet I was able to go in either the left or right lane… meaning I could go right into oncoming riders.
After a bit, though, it fixed itself and bumped me back to the right lane only. I think it had to do with the fact that the road thru Repack Rush is twice as wide as the normal road. Since you can steer all the way across the Rush road, I think the little “transition segment”- which I think the left turn out Rush is one of the ones that doesn’t have that transition segment, just one road onto another, as evidenced by the minimap elevation profile- has the same characteristic. This transition segment was very long compared to other ones, so you could play chicken for a decent amount of time.
Not a huge bug, just thought I’d mention it. :slight_smile:


Got it. Thanks Shuji!

I just did the ZRacing race, first time using steering and it was awful. Random aggressive pulls to the right unprompted. Completely takes you out of the draft. Seemed to happen most often in the last 1-2 km of the lap. I’m guessing it’s location dependent because most of the time nothing happened…until we got to that section.

1 Like

People doing workouts in London are not having the workout icon appear in the rider list on the right.

Repack Rush in the route list doesn’t have a green square and I know it’s because there’s no route badge but it’s the only one and it’s very anti-aesthetic.

That’s been off/broken everywhere since ToW from what I can see

1 Like

I think it was in 1.41 that the Apple TV menu button problem I reported was flagged as fixed. I noticed at the time that it referred to the “back” button in the release notes, whereas my report referred to the “menu” button and I thought “that’s weird they called it by a different name for some reason”. Looking at images of the latest apple TV remote, it does not have a button labelled “Menu” like my early black touch remote does.

Why is this relevant? Well, the behaviour is still not the same as it was before. When I press the menu button, I still get a menu button appear on screen which I then have to press using the touch part of the remote. Previously, I used to just get the menu when I pressed the menu button. Speaking to someone else with an ATV in-game this morning, they said that when they pressed the “back” button they get the menu straight away. So if my interpretation of what was said is correct then the buttons on the respective early and late remotes are different and being interpreted differently.

It’s an issue for me because sweaty fingers and the capacitive touch part of the remote are not a good combination. If often interprets the initial touch as a swipe and the consequences of this are frustrating especially when you’re going a bit harder.