Game Update 1.18 - October 20th, 2021

A post was merged into an existing topic: Can’t U-Turn [October 2021] [1.18.0]

Updated zwift on pc tonight. 3 rides, 3 zwift app crashes within 20 minutes. This isn’t acceptable for the subscription fee. Fix ASAP.

v1.18.1 for PC, Android, iOS and Apple TV have not released yet - only macOS tonight.

We appreciate your patience until they’re out in the next 12 to 24 hours.

2 Likes

I am having power drops again after last update. I am using windows laptop with ANT+. I hadn’t have power drops in a while, and last few updates it go back and forth between having zero drops and having 2-3 or more.

4 Likes

I’ve got zero resistance post update. Gradient change, but no resistance change.

Running ATV and KICKR Bike

1 Like

6 posts were merged into an existing topic: Route selection scroll bar missing on Windows [October 2021] [1.18.0]

A post was merged into an existing topic: Mac blank screen, colored screen and black blocks [October 2021] [1.18.0] [SOLVED]

Following up on this - I also could not view another rider in a meetup. The button is there in companion app, but clicking it does nothing. Android, latest Zwift release running on PC.

1 Like

Riding Richmond yesterday (via Bluetooth) was an absolute disaster. Never had this problem before latest release.

1 Like

This is why new maps, rowing and running updates will never happen. The whole team is continually bug squashing (the same bugs) every minor update.

What problem? You need to be more specific.

1 Like

He quoted Hayley Walker’s problem with lagging gradients.

1 Like

Ah, thanks, I don’t have that issue. I don’t use bluetooth either, so perhaps that is why?

The one noted in the post that I responded to. Gradients on the screen did not match the resistance on my Kickr or Climb. In short, there was a considerable lag that was not the result of mere radio interference. For example, on the 23rd Street KOM, I was still tilted downhill and spinning at downhill RPMs for the first quarter of the climb, and, upon summitting, still had a few hundred meters of “climb” remaining, according to my Wahoo equipment. Nothing changed from my prior ride to yesterday’s, except for the new Zwift software.

2 Likes

Version 1.18.1 for PC and Apple TV devices has been released.

4 Likes

Chchchanges?

Yesterday after 1.18 update on a Mac, the ‘A’ button to open the pairing screen did not stop the avatar.
It kept moving.

After today’s update 1.18.1 when hitting ‘A’ button and opening the pairing screen stops the avatar as expected. But U turn does NOT work, either on the Zwift application nor on the Companion App.

I rode for 40Km without a single issue. I was able to select direction options without issues, and the speed of my rider seemed ok.
Then at some point I hit U button to do a U turn and it didn’t work. Tried with the keyboard, the button in the Zwift application and in the Companion App. No way to get it to work.

And after hitting the U button, everything started going wrong… Route directions were totally ignored. No matter what I select, the avatar would go wherever it wanted. The speed of my rider was totally off. I was pushing 2.7 w/kg on a -6% descent and the speed was 18 km/h… People doing 1.2 w/kg would pass my like airplanes.
Even saw a rider supertucking UP de Alpe du Zwift! He was going up without pedaling at 70 km/h on supertuck position!.

Is this a know issue?.
Thanks!.

Yup: Can't U-Turn [October 2021] [1.18.0]

Thanks Dave!

Version 1.18.1 for Android devices has been released.

1 Like