Freezing middle of ride

twice now its frozen half way through a ride. Anyone else having these issues the last few days.

Hi @jason_Rowe

Welcome to the forum.

We will need more information to assist you.

Lets start here: Guide to Getting Useful Support?

2 Likes

Twice now in 3 days zwift froze. Had internet connection and other devices worked. It froze wouldn’t let save the ride and the only way to leave was close it down. Message said zwift not responding.

Hi @jason_Rowe
Sorry for the crash.
As Gerrie mentioned ( thank you G! ) we really need more info.

Platform, Game version, Trainer, Pairing protocol, World / Route you were on, whether you were in an Event or Workout, etc.

are all great things to include in an initial report, especially for a crash / freeze.
The link Gerrie sent has more complete info.

Off the cuff, we are not aware of any wide-spread freezing in middle of rides, but we are very concerned about such reports.

Thanks for your post,
Will

1 Like

platform PC
Trainer elite directo
Watopia 1st time pretzel 2nd time big loop.
Ant+

Did you check the PC temp? Maybe it’s overheating.

1 Like

I’ve had the same problem.
Zwift froze five times.
Was doing the SAS ride at 6pm Australian EST (last night my time)
Was on Fergo’s Flats.
Wahoo Kicks (only four months old - Ant connect)
My lap top is only 3 months old and only used for Zwift - excellent internet connection.
After freezing so many times I jumped into another event - Australian Crit Crushers and it worked perfect.
Then jumped back into another SAS event at 7.05pm - Froze again a couple of KM in and then again at around 26km in to the ride?
Very annoying!!!

Temp was fine on PC was only on it 30 mins 1st time & 40 mins 2nd. Its well ventilated. If its only twice I can take that gliches but just annoying when you are having a good ride

3 times now its frozen!!! Never had this problem before latest update. Zwift what have you changed??

Maybe send log files and a support ticket to zwift.

I have had recent issues with Zwift Freezing, “not responding” mid ride.

I have opened a support ticket but have not heard back yet. The most recent freeze was yesterday when I was attempting the 25 laps of Volcano. I did a fresh reboot of my PC, launched Zwift then joined Zwift with the volcano route selected. I was just waiting in game for a friend to join and the app froze.

I relaunched Zwift and it worked for 2.5 hours then on lap 24 of 25 it froze again and I lost my chance to get the 25 laps completed.

This has happened several other times including mid race and other long route completions during a meet up.

I have ensured I have all of my drivers updated and windows updated

My setup:
Garmin Ant+ Dongle on a 10 foot extension cord withing 2 feet or less of trainer and PM
Hammer 1 Trainer connected via ANT for FE-C Control
Hammer 1 Trainer connected via ANT for power
Powertap P1 pedals connected via ANT for Cadence (I typically use my pedals for power but only one side was reading today, I have had zwift freeze using either power sources)
4iiis Hear rate strap connected via ANT for Heart Rate

For this freeze I had music playing through a Bluetooth headset via iTunes (I have had Zwift freeze when I play audio through my phone or through my PC)

For this freeze I was running a discord video chat however I have had freezing when I was not on discord as well.

[8:05:10] Game Version: 1.0.51959
[8:05:10] Config: Shipping
[8:05:10] Launcher Version : 1.0.39

The Last FE-C SIM GRADE change occurred at 10:46:35 in the logs but kept capturing Power meter data until I force killed Zwift through windows task manager

System Information

  Time of this report: 6/21/2020, 07:58:30
         Machine name: ZWIFTMACHINE
           Machine Id: Unknown
     Operating System: Windows 10 Pro 64-bit (10.0, Build 18363) (18362.19h1_release.190318-1202)
             Language: English (Regional Setting: English)
  System Manufacturer:                                  
         System Model:                                  
                 BIOS: BIOS Date: 06/15/12 20:54:21 Ver: 04.06.04 (type: BIOS)
            Processor: Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz (8 CPUs), ~3.5GHz
               Memory: 12288MB RAM
  Available OS Memory: 12266MB RAM
            Page File: 5680MB used, 8441MB available
          Windows Dir: C:\WINDOWS
      DirectX Version: DirectX 12
  DX Setup Parameters: Not found
     User DPI Setting: 144 DPI (150 percent)
   System DPI Setting: 96 DPI (100 percent)
      DWM DPI Scaling: Disabled
             Miracast: Available, no HDCP

Microsoft Graphics Hybrid: Not Supported
DirectX Database Version: Unknown
DxDiag Version: 10.00.18362.0387 32bit Unicode


Display Devices

       Card name: NVIDIA GeForce GTX 780
    Manufacturer: NVIDIA
       Chip type: GeForce GTX 780
        DAC type: Integrated RAMDAC
     Device Type: Full Device (POST)
      Device Key: Enum\PCI\VEN_10DE&DEV_1004&SUBSYS_84691043&REV_A1
   Device Status: 0180200A [DN_DRIVER_LOADED|DN_STARTED|DN_DISABLEABLE|DN_NT_ENUMERATOR|DN_NT_DRIVER] 

Device Problem Code: No Problem
Driver Problem Code: Unknown
Display Memory: 4095 MB
Dedicated Memory: 3029 MB
Shared Memory: 1066 MB
Current Mode: 1920 x 1080 (32 bit) (59Hz)

I still have all of the logs saved off from the zwift\logs folder if there are any details someone might need to troubleshoot this further.

I would start with Windows update and check for a GPU driver.
And Windows System File Checker
https://support.microsoft.com/en-us/help/4026529/windows-10-using-system-file-checker
helped when I had crashes (not Zwift, that happened never in 9+ months through winter 2018-19 and 2019-20).

Edit: Check your log files:


And Windows Event Logs could be some help, too.

Unfortunately it looks like my SYSTEM event logs have purged…

I will gather that next time.

As state previously windows and video drives are up to date.
System File Checker came back clean however I was having issues running this command as it came back saying the source file could not be found:
DISM.exe /Online /Cleanup-image /Restorehealth

As a result I ended up following some other recommendations to re-upgrade Windows 10 and now the DISM.exe command comes back clean as well as SFC.

My next zwifting is tomorrow(6/24) at 5:45pm Pacific when I do the last USAC race, hopefully no crashes there. If/when I crash again I will pull the additional logs.

Here are the zwiftalizer results, not quite sure what to gleem from them but it is interesting that ant+ still is sending data but there is no more rendering happening.



And frozen again…
This time 50 minutes into the race.

Nothing interesting in the event viewer logs but I will post them later. I think it might be time to go back to full time Trainer Road I still have not heard back from Zwift support on the first crash. This is just ridiculous.

I will post all the logs later, gotta do the dad thing now.

Have you got the automatic screenshots turned on? Perhaps it’s creating a spike that your computer can’t deal with.

1 Like

I do have auto screenshot turned on however the Auto Screenshot did not happen during the freeze event, this is the last screenshot entry in the log:

The freeze occurred sometime around 6:44:43 based on log reviews when the last FPS entry was.


This is interesting though I am not sure how valuable. This is the timestamp of the last FPS entry, the resize entries happened two other times in the log without a freeze and I am not sure if the “player packet older than 10 seconds” is a result of the freeze or the cause of the freeze:

I said F it and re-formatted my Zwift PC. It is now completely wiped and fresh, I won’t be Zwifting again until Sunday or Monday but hopefully it is now resolved.

Gerrie, The exact same thing is happening to me and has only start in the last couple of weeks. all my equipment is new (KickR, lap top, Ant, cords etc - everything!). Clearly an Zwift issue so what do I do?

Same thing here, regular freeze.

I’ve got a win10 PC / Nvidia 1050, using iphone as zwift companion to connect trainer and co.
Almost 100% freeze after random time into the ride

PC is running fine 24/7 with video games / browsing / IA GPU Dev…

Getting bored

I might have gotten this resolved. I did a memtest84 and got thousands of errors. I have since replaced the RAM and have no errors on memtest84.

I have only had time to do a 1 hour zwift session since the new ram but no issues after that session. I have had some chest stuff pop up since then so hesitant to jump back on the trainer.

You might consider running a memtest84 though, this was the first time I ever had bad ram. Even with the bad ram I could run a 5 hour furmark GPU stress test with no issues.