Flickering after Dec 17 Update

Thanks - any links/instructions on this one?

See your PMs.

Thanks buddy that worked a treat! Back up to high-refresh 120fps with 0 flickering :smiley:

Will this workaround still work next time there’s a game udpate? Will I need to downgrade again?

1 Like

Game updates happen independently to the launcher, you’ll get them as normal.

I am not affected by this but it seems crazy to me.

Someone says they have this issue, you send them the old launcher and it fixes the issue and Zwift seem to deny there is an issue or that this fixes it.

What are the benefits of the new launcher? why not just roll it back to the old one?

As I understand it, the current version of the installer (I keep calling it the launcher) has the following major changes over historic versions:

  • Includes at least one C++ redistributable package which improves Bluetooth connectivity on first install - there was a big thread on here where someone figured out the problem of Zwift saying there was no Bluetooth device installed; the newer installer attempts to address that natively by bundling the necessary package. This is why the filesize of zwiftsetup.exe is much larger than it used to be.
  • Addresses a security concern with the Internet Explorer login by updating TLS support.
  • Allows for multi-threaded extraction of game updates, supposedly to improve install/update times.

None of which should affect in-game performance, but I believe the last one of those fundamentally changes something, because in my testing it’s patcher.dll (one of the files that change depending on the installer version used) which seems to be the problematic one. All the others can be manually copied back and forth with no impact, including the C++ stuff.

Also worth noting that the launcher never used to check or update itself, but nowadays it does (though the prompt can be ignored). So I expect the vast majority of people are using the latest version. As will virtually everyone who’s installed Zwift from scratch since December.

However, aside from the stuttering it also introduces - which I can see at all times - the flickering only shows up at high frame rates. Most people will be using a TV or other 60Hz display and so by default Zwift will be capped at 60fps by vsync, hence why there aren’t that many complaints about this. The problems are only relevant if you’re bothered about smoothness and/or using a setup which produces high frame rates. I fall into both camps.

yep - that is my set up so likely why i don’t see it.

zwift must test stuff at higher rates though?

chuckles

3 Likes

Thanks, worked like a charm!

1 Like

Got this on my system now, since I can’t use 1.0.50 any more.

This is at stock settings, so without even disabling vsync (which forces it to appear a lot more often). My GPU and monitor are now worthless for running this game, since high frame rates are penalised and adaptive sync isn’t smooth, which is the whole point of it. Streamable Video

1 Like

Is it the same on all worlds or jerseys or bikes etc? any better or worse than others? (sorry if you have answered this many many times!)

I think it could be the length and pinkness of your socks!

The stutter happens everywhere. Flicker occurs at high frame rates, so Watopia and London are the worst for it and it probably wouldn’t show up on Makuri Islands even with a 5950X and 3090.

That’s not me btw.

I’ll forgive you for the questionable sock choice then!

2 Likes

It happens for me, I haven’t noticed it to be different on the ride it just seems to do it all the time. This has been happening for a lot of months for a lot of people. Come on Zwift hurry up with a fix it shouldn’t matter what pc you use it should just work. It’s not free you know Zwift. If a TV was flickering you would take it back

3 Likes

flickering is back with a vengence :frowning:

capping fps to 60 seems to help with the flickering but not 100%

any other workarounds?

kinda glad I let my membership lapse

There aren’t any workarounds I’m afraid. There’s a way to force the game to still work on 1.0.50 but it’s no different any more, suggesting some server end changes that were brought in with 1.0.51 are now everywhere irrespective of launcher version.

All you can do is add your voice/vote here in the hope that they address it: New launcher (1.0.51) causing stutter on Windows systems

1 Like

Would turning on vsync or capping at 30fps help?

Still getting flickering every couple of seconds capped at 60fps.

I also replied to that thread. Seems zwift dgaf.

You should have vsync enabled anyway. :wink: Though I suspect driver/display sync is what is causing the stutter at present.

But yeah, capping the frame rate at something low usually sorts the flickering. Obviously this shouldn’t be necessary.