Gaming PC Avatar Flicker

Hello, I am experiencing avatar flicker were all the riders including myself are flickering see through. The computer is brand new with intel i7, gtx 1660ti gpu, 8g of ram. I have been trouble shooting this issue. The computer and nvidia gpu are up to date. Zwift is running current version. I have tried different performance settings on the computer that didn’t help. The problem is extremely bad in 1080p and get better in the 4k setting. I have checked the log file in zwiftalizer and I get over 100 fps 1080p and 60+fps 4k. My internet connection is excellent even connected to the lan directly. Does anyone have suggestions or is this an issue with the current version.

For comparison I have a MacBook Pro M1 that runs high graphics detail at 1080p 45-60fps with out this issue annoying flicker

Is this happening all the time or when you are participating in group events?

All the time. Everything else in the graphics are perfect the whole body of the avatar flickers see through

In that case I’m at a loss. The hardware is capable. Have you tried dropping the in game quality from high to low to see what happens there. You should be able to have it on 1080p without issue.

There must be some form of slight incompatibility with your hardware and Zwift. Also try a different version of the drivers or some generic Windows drivers.

Thank You for the suggestion about the drivers. I went directly to Nvidias website and updated the driver for the gpu. Everything appears to be working. Ultra graphics are stunning.

This is nice to hear!

I’ve just renewed my Zwift subscription and seeing similar. My rider and shadow have annoying flicker, my rider and shadow disappear for a split second every second or so. Its only my rider, when it disappears briefly you can see the bike handle bars etc. Its not other riders. I’m running on a Dell G5 laptop with Nvidia graphics. I think my G5 has a 1060 graphic card from memory.

@Steven_Carpenter what version are you running to correct problem?

TIA!

The flickering is due to one or more of these three things;

  1. Using the newest launcher.
  2. Having unstable GPU overclocks.
  3. Running an unnecessarily high frame rate (for example with vsync off).

Reinstalling the driver probably addressed point 3, if the OP selected the box for a clean install which would revert them to default vsync behaviour (‘Use the 3D application setting’). Also explains why running 1080p seemed to be worse than 4K - since the frame rate would have been significantly higher.

I have successfully replicated this issue. It goes away completely with the previous launcher version even at those very high frame rates.

Thank you Dave, helpful info. I also have dual screen, could that affect it? I ran zwiftalizer, the numbers are green for frame rate, so I assumed good?

I don’t overclock, that I know of, just a standard install of drivers.

This is a fresh install of Zwift, so I don’t know how I can try an old launcher?

Looks like you’ve got vsync turned off. Just change the setting back in the Nvidia driver. Or I can send you the old launcher if you want, you just overwrite it (no need to reinstall the whole game).

PS: you should be running the 4K setting, or 1440p at least.

OK, think you fixed Dave, thankyou. Quick test, and no flicker, but it was heavy rain in London so hard to tell :slight_smile:

The vsync setting in 3D options in control panel was set to something like ‘Use Application Settings’ I change on ‘ON’ and flicker gone.

The laptop is connected to HD TV, so I cant go higher than 1080p ?

You want it on ‘use the 3D application setting’ really. But it’s the same outcome in Zwift anyway. The frame rate is still higher than it should be, so I doubt anything has changed yet. Probably just that it’s busier. I’d put a cap on your FPS at 61fps.

With your GPU you can select any resolution you want in Zwift, it’s within the game settings menu. Higher looks better, even on a lower native resolution display. Run what it’s capable of.

OK, vsync now back at ‘use 3D App setting’, and Game now set to UHD, no flicker :slight_smile:

Thank you so much!!

Now it’s too low. :rofl: I’d go with the middle ground of 1440p and cap it at 61fps in the driver.

I get the jist, I think the zwifalizer numbers are low as its just a short period, fps low at start then speed up through game, I have the fps showing on game.

You want it to be a nice steady 60fps as often as possible, assuming you have a 60Hz display. You won’t manage that in a group ride or really busy area because of how Zwift works, but otherwise it’s about finding the best balance of image quality and consistency of frame rate.

Where can I get the “old” lancher?
I had an old installation of zwift and could run it at 2k with 144HZ no FPS cap.

I switched from an i5-7600K to a ryzen 7 5800X, reinstalled zwift and now its flicker flicker party time :confused:

caping the fps at 61fps works but…what the ■■■■ its 2021 :rofl:

The old launcher won’t work any more, I’m afraid, so that’s no longer an option.

But see New launcher (1.0.51) causing stutter on Windows systems - #49 by Dave_ZPCMR