(Fixed) Oct 16 update - crash iOS 13.1.2

The app was updated this morning (v1.0.41097). I am on iOS 13.1.2

App opens, can pair sensors, can load a training session, tap ‘Ride’ and then about 1-1.5 seconds later, app crashes.

Tried double-tap, swipe to kill app.
Tried rebooting phone.

Known issue? Fix soon?
Thanks.

Also, tried a ride without a training session - same issue

There is yet another Apple IOS update available (13.1.3). It may be that this is causing a problem. Not 100% sure but it is possible.

1 Like

Thanks. But no. :roll_eyes:

Tried uninstall / reinstall. Nothing.
Tried iOS 13.1.3. Nothing.

I sent a ticket to Zwift support. Will see :man_shrugging:

1 Like

I am having the same problem. Help?

2 Likes

I reported this issue ~15 hours ago to Zwift Support too and have shared my logs.
Impacting iOS 13.1.3 and Zwift iOS App 1.0.41097 (released in the previous 24 hours).
Reinstalling app, restarting, etc. did not resolve either.

3 Likes

One of the support team from Zwift wrote this to me:

I’d like you to try uninstalling Zwift, rebooting your phone with a force restart (instructions can be found here​), and reinstalling Zwift.

And that seemed to work for me. I can now get to the ride screen. However, at the time of testing it, i wasn’t in a position to connect any sensors. I will try that today.

But at least the app is working more ‘normal’ now!

Thanks. This seems to have worked for me after having same issue today.

I tried that 2x, but it didn’t work for me. Thanks,

Same bug for me! :face_with_symbols_over_mouth:

Same issue here. 13.1.3. Prior version of Zwift was flawless on 13.1.2 and 3. Not sure if I’m on to something or not but if I skip pairing initially and select “Ride” it doesn’t appear to crash. If I go back and pair and then back again I think it’s working. Need to test it more tomorrow but this may be a temporary work around.

3 Likes

Hi!
I just upgraded my iPhone 8’s operating to iOS 13.1.3. As soon I go to start ride (structured or unstructured workout) the app crashes.
Help would be greatly appreciated!

Same ■■■■ here…Why cant they test it before release​:exploding_head::gun:

Quick response from Zachary at Zwift:
We’re sorry to hear that you’re experiencing issues with Zwift crashing. I’ve checked with our team, and they’re actively investigating this issue. Currently, we’re aware that Zwift is crashing for some users with the latest iOS update. However, the good news is we have a workaround that should help. To do this workaround, please be sure that you’re not pedaling at all when loading in after pairing. If that doesn’t work, please skip pairing until you’re completely loaded into the world you selected, then go to the menu to pair from there. Keep in mind, this is only a workaround, and the fix will come from our end, so all you should have to do is keep your Zwift app up to date.

5 Likes

I am having the exact same problem! Haven’t been able to ride for two days because of this ever since the 13.1.3 update. I can connect but once I launch to start riding it crashes. Uninstalled, reinstalled, etc.

Zachary’s 2nd work around option worked for me.

Same for me today

Neither works for me. I havnt been able to access for a few days, really is impacting my training schedule. Do we have an eta for a fix?

We had at least 12 riders impacted in our A category alone for a race today, possibly as many as 40 riders. This is a serious issue.

Searching I found this post in the forums: Ride App Crashing on Start: iPhone 6, 8 and 10!

I confirmed I was able to use app by: 1) just watching, 2) menu, 3) hit bluetooth icon on right, 4) connect, 5) back to me

Would be great if Zwift could at least surface the workaround via twitter and other mediums.

1 Like