Error Z104 SOLUTION PLEASE

Hello, I have installed the program, and once installed when it starts I get the following message Z104, I have tried to install it in different places, and I have even changed the disk, but always when it starts I get the message, and it won’t even let me start the program, someone would know how to give the solution, I have been consulting the technicians since Saturday and they have not answered me, Thank you.

Hi @Javier_nicolau welcome to Zwift forums.
Is this a work computer that’s administered by your IT Department?

Please see our support hub article on what a Z104 error means.

1 Like

Hello, It is my computer with a single user, although with an access password yes, I saw the article, and I have done everything it says, but there is no way, sorry I am new. Thank you. Sorry for the disturbances.

@Javier_nicolau
Please confirm each of the following:

  • You have admin access on their computer (meaning you are able to install & uninstall programs)
  • Check any anti-virus programs software firewalls and allow Zwift to run on them.
  • Check there are no backup programs (such as Dropbox or OneNote) attached to the Documents folder. These will interfere with the Zwift app.

Lastly - is this a Windows10 computer? Please make sure that Microsoft’s .NET 3.5 framework is installed.

Hello, I have installed the Frame 4.5 version, which is higher than the one you indicate, I do not have any cloud configured, and if I am the administrator, therefore I can install and remove what I want, and the antivirus disconnected it during the installation, but the error is always the same. Zwift support has been unanswered for more than a week, I need help, thanks for the information, but the error still appears. The error is ZL04, I am attaching an image, which is not mine, but it is the same message always, until the program is restarted. Thank you very much, sorry for the inconvenience.

It needs to be .NET 3.5.

Hello, I have version 4.5 installed, it does not allow me to install a minor version, and I do not know how that version can be removed since they are files, updates. You could help me Thanks.

Yes, you can and have to install 3.5
Google it.

.net 2.0 and 3.5 and anything above 4 are totally different things.

If it’s Win10 go to Control Panel>Programs and Features
On the Left-Side click on Turn Windows features on or off
Make sure .NET Framework 3.5 (includes .NET 2.0 and 3.0) is checked.

Hello, sorry, I have it activated and activated and deactivated the superior version in case it was a compatibility problem, but nothing continues to appear the message, I attach a photo to you. Thank you very much for trying to help me.

OK, are you an admin on that PC?

Have you tried right clicking on the icon and running as administrator?

You could uninstall Zwift, delete ALL the files and folders in Documents\Zwift (you can make a copy if needed and place on your desktop), restart your computer, re-download Zwift and reinstall Zwift.