Erg works in BT but not ANT+

After trying all sorts of fixes, Zwift erg works in BT but not ANT+ (Kickr with Dell Laptop W10). I have an ANT+ extension cable/dongle and the paired connection is very solid with no dropouts but erg is absolutely non-functional in ANT+ but works in Bluetooth on a weaker signal. What am I missing?

Are you connecting it using the FE-C option for ANT+ in the Zwift Pairing scree?

Yes, always ANT+FE-C and no erg.

Same problem myself William , been racking my grey matter , dumbfounded , i got no answer , same gear kickr v4 (2018) and win10.

This may help.

1 Like

My kickr core works fine in ERG mode, also on windows 10 and ANT+

Yes, aware of the pairing process and no problems pairing either in ANT+FE-C or in Blue Tooth. The problem is that ANT+FE-C results in no erg function and BT has erg but not as solid of a paired connection. One thing I am going to try today is ANT+FE-C without the extension cable, situating my laptop much closer to the Kickr load generator — because it occurs to me that the extension cable (9 feet long) is the only difference in my BT set-up vs. ANT+FE-C, and I’m thinking that the extension cable itself may be impairing the signal. The other difference I’ve noticed is watt readings in BT are real-time (no lag) whereas there is a decided lag in those when in ANT+FE-C with the extension cable.

Unfortunately, eliminating the extension cable and plugging ANT+ dongle directly into laptop USB port was no solution in getting erg to work. I rode a regular SIM session using BT pairing for all and connection was very solid — post-ride I restarted Zwift and confirmed that erg is still functioning for me with BT connection/pairing for Kickr and HRM.

Possibly the ANT+ dongle isn’t a good one.

Possibly but it does connect solidly it’s just no erg function and the lack of real-time of the metrics displayed (watts and cadence delay) is very noticeable especially compared to the BT connection, the latter which also enables erg.

Thanks for the videos guys , im not new to zwift , 2 years , lvl 50 , I inderstand how to pair , I understand erg mode , what I have noticed from wahoo kickr v4 (2018) , the red light stays on for ant+ fe-c signal , which is also power light , tells me its paired , however in zwit it never flickers , when I pair in bluetooth blue light goes from fast flicker , pre pair , to a solid blue with a slight flicker after pair , in ant+ fe-c there is never a flicker , when it is paired correctly there is a slight flicker , I have swapped out dongles , usb plugs etc .

Mystery solved thanks to Luka. The ANT stick I have been using was purchased new from Amazon a couple of months back along with a 9 foot extension cord. I never imagined it could be a problem, especially since it paired and connected — apparently just not very well! After reading Luka’s above post, I borrowed a Garmin ANT stick from a neighbor and problem solved, erg now works and all metrics read in real-time without lag. I’ve order a Garmin ANT stick.

1 Like

Thanks for compliment William , I’m still trying to chase the issue , got some gear ordered , usb extension cable , another ant stick , etc , once its delivered will test and report .

After having placed a few items in the Amazon cart , just got delivery .
I just started swapping out gear , but I did order a powered usb hub a zwitalizer recommendation and a new usb extension cable .
Having set it all up and moving the ant+ dongle a little to the left , on the flywheel side of the trainer , light from the hole appears , it all looks good and the red light on trainer has a slight flicker , another symptom is the data doesn’t upload to garmin connect if connection isn’t solid . Hopefully fingers crossed connection will hold .
I cant say with certainty what is the actual problem , power issue from usb port , loose usb port with the existing usb extension cable , its up and connected .
My setup was solid for 2 years , my envionment didn’t change , I cant why say it happened .
Hopefully others can find some help in this thread .

My last laptop had usb ports that would go flaky. I use a usb mouse (hate trackpads…) and every now and then I would have to swap ports to try and get it working again. Luckily I had 4 ports to play with but one was definitely touchy quite often. No idea if a driver issue, mechanical connection issue, or phase of the moon/spirits issue.

No issues, so far, with a new laptop.