Erg not functioning

I have a 2018 Kickr with a Dell laptop running W10 and Zwift works great except for erg. I have a good ANT+ connection (extension cable) for watts, etc. and HR is through Blue Tooth and that is solid as well. I make sure the erg box is checked (in workout area) and then get into my ride. The structured session is detailed on the left but the resistance never changes — just like riding SIM except it’s in erg and supposed to be controlling the resistance. I am at a loss as to what is wrong. I’ve checked with Wahoo and all seems well and properly configured through their app.

do you use the ANT FE-C option when pairing?

Yes, and the connection is solid, no dropouts and/or pauses.

I would try a zwift re-install and see if that helps

1 Like

But the resistance changes when going uphill on normal routes? I assume that relies on FE-C, too.
There is no change even if you keep a steady cadence and hit a block with a significant increase in resistance?

When I tried my first workout, I noticed that I kept adjusting my cadence which in its turn resulted in me fighting ERG, I guess. When I kept a solid 90 rpm, I noticed that the resistance did increase. To be honest, I though that ERG was something like “the trainer slams 300W at you and as long as you pedal, that’s what you produce”. At least the Tacx Flux S is not quite like that.

No — for instance yesterday I was to do a workout involving 4 x 8min. at Lo-Revs and higher watts. I kept my rpm absolutely the same all the way through the warm-up and then for the 1st 8min. int. and there was no change at all in resistance either from topography or the session’s structure (which was listed on the left and showed me going through the various segments). When I downloaded the session to Golden Cheetah it likewise showed no watt changes. Essentially, there was no control of my Kickr resistance coming from the Zwift erg function. As suggested above, I have uninstalled Zwift and reinstalled it and I will try it again later this morning.

1 Like

How do you pair the trainer?

My initial post above details all of that — ANT+ with extension cord. The connection is not the issue. I also uninstalled and then reinstalled Zwift and tried an erg session and no change at all. Essentially erg is nonfunctional for me in Zwift.

Just for fun, does it work without the HR monitor being paired? Have you tried that yet?

I have not tried that and I will tomorrow but what would be the theory as to why that would make a difference? I suppose I could also pair the HRM through the ANT+ as well?

Played with part of erg session 1st and got it to work using ANT FEC for HR instead of Blue Tooth but downside is lots of HR dropouts during my ride today, as ANT FEC is extension cable on floor next to Kickr so HR strap having problems – will try new battery in HR strap. Previously I was pairing HRM with Blue Tooth dongle on my laptop and that was very close to HR strap but it seems the Blue Tooth was also interfering with erg function (Kickr was always paired via ANT FEC).

My HR is also paired with ANT and my dongle is on the floor under the trainer, I don’t have signal strength issues. I think the new battery might be the trick.

Not a solution unfortunately and I need HR metric so I’m back to HRM paired via Blue Tooth and Kickr paired via ANT+ FE-C — erg still not functional despite working things through with Wahoo (Kickr and its software seems not to be the issue).

I’m having the same problem. 2018 Kickr Snap connected via bluetooth through the Companion app.

Start up Zwift, ride a few minutes, then start a workout. ERG mode doesn’t function. Try turning ERG mode off and on - still doesn’t work. And the power readings are erratic - definitely not accurate. (I usually have “3 second average” selected for my power reading in Settings, but even if it were “Instant” the variation in reading would be too much. Zwift is not reading the power output from the Kickr correctly.)

So, fast forward through the workout, exit workout mode, fiddle with some settings (change trainer Difficulty, change from 3 sec average to Instant). Start the workout again, and everything is fine.

Yesterday I was able to get erg to work by pairing HR and Kickr both via Blue Tooth but signal was poor and some dropouts (W10). I have ordered a supposedly better Blue Tooth antenna/dongle for insertion into a USB port (arriving Thursday). I tried putting my existing BT dongle on the end of an extension cable near the Kickr resistance unit but had zero connectivity/pairing showing for that — it seems that my existing BT dongle is only functional when plugged directly into a USB port and I’m wondering if BT dongles simply don’t work on extension cables?

The last time I tried bluetooth directly to my PC it did not go well. Zwift does not seem to have this sorted yet. Using the companion app is much more reliable bluetooth conduit. If you can, give it a try.

1 Like

My eyesight isn’t good enough to use my phone for Zwifting.

1 Like

I’m getting a similar issue using a Sarris H3 and an iPad connecting via Bluetooth.
It starts off fine, but when the work calls for a change in power the trainer does not adjust resistance.
I have to stop, let the erg mode temporarily disengage, then start pedaling again and when erg mode engages it does so at the correct resistance for the desired power output.

Interestingly enough erg mode works fine in Rouvy, so I’m doubting it is the trainer or a connection issue.

1 Like

Same here. about 3 or 4 days ago this started for me. ERG worked find for workouts for months previously. I posted more details in a different thread titled “Erg mode in Build me up plan”.

My basic problem is when the workout changes the wattage in an interval, the resistance doesn’t adjust for 30-60 seconds. Really frustrating and hard to complete workouts in a training plan like this.

I’m using Kinetic Power Unit on Rock and Roll. Windows 10. Iphone 11 with companion app.

For me the solution was replacing the ANT dongle, which was surprising because the one I had was new (purchased from Amazon) but apparently defective.