ERG issues on latest update?

Since the last update this past week on ZWIFT—my ERG mode does not register; I have resistance, just that ERG on is no different than ERG off. Anyone else having this issue or fixes?

Hi @P_Lapekas

Welcome to the Zwift Forums!

I had a look at your account and it seems that you are using a Windows 10 PC for Zwift and pairing a Wahoo KICKR via built-in (native) Bluetooth LE (BLE).

I did notice some various BLE write errors and BLE disconnect and reconnect errors, but that was for your ride on March 18th. The more recent rides you’ve done don’t have BLE errors, so I don’t think that BLE interference is likely the cause of the issue.

Can you try using the Zwift Companion (ZC) app as a BLE bridge to pair your KICKR to Zwift instead? I’d be curious to know if the issue goes away when using that pairing method. You can find more info in the Using the Zwift Companion App as a Bridge section of this article.

Also, do you have a USB ANT+ dongle and if so, would you be willing to try ANT+ pairing? I’d be curious to know if the ERG mode resistance works when pairing with ANT+ instead of BLE. You’ll find more info in the Pairing with ANT+ section of this article.

Furthermore, have you calibrated your KICKR recently and updated the firmware? If not, please do so and you can find more information in this article.

Lastly, have you done anything else to troubleshoot the issue? For example, have you tried powering off your KICKR for several minutes (e.g. unplug the power cord) and then turning it back on? Sometimes that can clear out any weird buggy behavior with the trainer.

Thank you very much for the rapid response. I am on the road traveling for the next several days so won’t be able to test this suggestions…but everything was working fine til the last Zwift update earlier this past week. As for your suggestions below I will try to ANT+pairing (as I use a USB dongle;

On Tuesday I tried to “calibrate” and the zwift would not allow me to do so…even when I hit 22 and 23 MPH—which was at a very high resistance in the system and had never been in the past…so that failed multiple times when I tried…as. it had been several months since I had calibrated. (And never had problems before).

I have not done any firmware updates on the Kickr so will also do that next week.

Lastly—I had unplugged the kickr. Multiple times; as well as my router (trying anything)…to no avail.

Will keep you posted next week.
Thanks again
Pat

Moderator removed personal information.

1 Like

Yes! I had the same issue yesterday. Tried various routes, worlds and training plans same problem. ERG shows on but completely non functional. Tried toggling off and on - non responsive. Zero issues with ERG until most recent update.

Hi Dawn @D_Bardon

I checked your account and for yesterday’s ride your KICKR was connected to Zwift with one half (the “Controllable” resistance part) paired via ANT+ FE-C and the other half (the power part) paired with Bluetooth LE (BLE).

Normally (according to your ride history), you pair everything with BLE and only pair your Heart rate monitor via ANT+.

Next time, try keeping your KICKR paired consistently for Power and Controllable on the pairing screen. It shouldn’t matter whether you pick “Wahoo FE-C” or the “KICKR 92BB” BLE option, but just make sure both Controllable and Power Source are the same, not split paired differently.

Please let me know if that helps!

Hey, thank you for speedy reply. Update today failed and app was stuck on “updating” screen. Ended up having to uninstall and reinstall. I was careful about making sure both paired via BLE after new install. Everything worked great!