ERG stops controlling power after about 40 minutes

I am doing a workout and after about 40 minutes (not exactly, but thereabouts) the ERG stops changing the resistance in line with the target wattage - this happens on most rides and seems to get “stuck” at a rest portion (i.e. does not increase at the next change as it should). I have tried skipping a segment, turning ERG mode off (does not seem to turn off), disconnecting and reconnecting trainer - none work. Using a Tacx Flux Smart and Windows 10 on Ant+ - Closing Zwift and reopening seems to work, but that is not really an option mid workout…

Any thoughts about what I can try? Might try using my phone later to see if it works on that, but much prefer the larger screen of the laptop.

Is it possible that erg mode is disengaging because the trainer can’t produce the power being asked of it? I know you said it seems you can’t turn erg off, but perhaps it gets “stuck” and unresponsive under these conditions.

Judging by this Tacx page, the gear you’re in and the cadence you’re riding at are significant with the Flux:

https://tacx.com/erg-training-flux/

e.g. if you’re in a 39x19 and pedalling at 95rpm, and the rest interval asks for 100W, the Flux can’t generate that power.

If that’s what’s happening, you could try changing gear during reset intervals, or lowering cadence. In the graph above, at 39x19 gearing you could pedal at 60rpm or change gear and the Flux would be able to generate the 100W resistance being asked of it.

I’ve absolutely no idea if that’s actually what’s happening for you.

1 Like

Thanks for the reply, Daren

Unfortunately, I have tried changing gears etc and the issue arises mid workout in zones which have already been used in the workout - it is very odd!

By “disconnect and reconnect” the trainer I assume you mean re-pairing it. You could also try:

  • unplugging and re-plugging your ANT+ dongle
  • turning the trainer off and on again

I don’t know what effect that would have on the workout, mind.

Do you pair your trainer as ANT+ FE-c in the paring screen.

Can it be that you trainer overheat and goes to a safe mode?

It could be the overheating - maybe I need to improve airflow if this is a thing. I have recently moved it to a new location in the room (at the behest of my wife)!

It is paired as FE-C and works for the majority of the ride (and until the last week or so has worked for long rides too - up to four hours).

1 Like

Maybe try a small fan to help with air flow. You can also try using bigger gears that will make the flywheel spin faster and thus help the trainer with it’s internal cooling. At high flywheel speed the trainer will also use less power to apply the brakes and therefor stay cooler.

1 Like

I have a flux and gearing is quite important - I find that if I am in the big ring and somewhere in the middle of the cassette spinning anywhere near to 90 RPM and the minimum wattage it will go down to is about 200watts

try keeping it in the small ring if you don’t already.

I’ve never had a problem with overheating so probably not that

Thanks, Chris. Pretty sure it is not gearing as working perfectly for the first portion of workouts. The image is the workout and I have highlighted the last segment which worked and the first which didn’t. They were exactly the same, but you can see the power output was drastically changed despite being on erg mode throughout…

Are you on the latest firmware? Might be worth checking that.

Have you tried different software to see if the same happens? It might not be a Zwift problem.

It’s also possible you have a faulty unit, and need a warranty repair - Tacx support would be the better option there of course.

oh yeah - that is weird.

they only issue I had with my flux was when I occasionally stood to pedal (going up a steep hill section or something) if the power cable wasn’t quite in properly it seemed to disconnect although the trainer seemed to stay on. Not sure if it flicked off and back on again or something. not sue if it was the movement on the trainer or what it was but doesn’t seem to do it anymore.