Power drops out, ERG mode disabled

Power reading from my Vortex Smart dropped out heaps tonight during a workout. That hasn’t happened in months, but the hardware/setup hasn’t changed. No problem reading cadence from my GSC-10 or my HR, which were obviously all the same distance away.

Anyway, what makes it worse is that then Zwift goes “ERG mode disabled” and reduces the resistance. Can that be turned off? I don’t care too much if the power reading stops for a few seconds as long as I can keep pedalling against the same resistance but it really screws up the rhythm when suddenly all the resistance is gone!

Hi Hamish,

We have not changed anything in regards to how we are reading power from a smart trainer. How far away, exactly, is your ANT+ dongle from the trainer?

That being said, “ERG mode disabled” was put in place for people who stopped so they can begin again (whether to go to the bathroom, answer the phone, or put out a fire). If something happens that causes you to stop in the middle of an interval, starting again would be akin to trying to pedal through concrete.

This feature works as intended and won’t be a problem once we can get to the root cause of the power drop outs :slight_smile:

Hi Eric,

The computer is about 4 metres from the trainer (Tacx Vortex). I’ve put my dongle on the end of a USB extension cable so it’s closer to the bike and all was fine today. Weird. It hadn’t dropped out in ages until last week.

I understand about needing to disable ERG mode during a break. Perhaps the timeout could be a little longer.

 

Hi Eric,

I face a similar problem, ie., during the workout, the wahoo kickr stops working suddenly with a message in zwift “ERG mode disabled temporarily”. The resistance is so extreme that I can actually stand on the pedal for a couple of seconds before it starts being normal again.

Thanks,
Prasad
UI Lead, Today’s Plan

 

Hi Prasada,

Is the KICKR on the latest firmware? And what platform are you riding on? PC/Mac or iOS?