ERG not holding steady

Hi all,

For the last few rides ERG mode during workouts hasn’t held the power consistent at all.

I use;

Garmin Vector 3 LS only

Tacx Vortex Smart trainer

Al connected to my PC though my ANT+

What could’ve changed and what can I try to correct this

Thanks in advance

  1. have you connected your trainer as controllable ANT+ FE-C.

Have you always used the Garmin Vectors as powersource? Having a different powersource may impact how the trainer perform in ERG.

yes, trainer is connected under the controllable option via ant+

no, not always, over the last 12 months. They have definitely been far more accurate than this though.

this is the workout i did yesterday - https://www.strava.com/activities/3037334029/overview

it was 2 sets of reps, with 3 sets of 5 min at 215w then 5 min at 240w.

normally you’d see the different sets, but as you can see the power is all over the place.

There should be more than one option for ANT+ one of them should specifically state FE-C

Like this.
image

looking at your strava workout it seem like the trainer was not changing the resistance. FE-C may fix that.

OK, thanks for the help Gerrie, I’ll check this tonight and see if it fixes the problem.

will the fe-c option show as another trainer when pairing? i’m sure i normally only have one option to choose from.

if you click on unpair then click search there should be two options.

something like this.

image

Also make sure your trainer is on the latest firmware.

Just tried connecting to my trainer, no fe-c option?!

Interesting? did you check your firmware?

See this post.

All up to date

1 Like

You got me stumped @Alex_Harvey.

Seem like you are doing everything correctly.

EDIT: Deleted my comment as it is not correct.

Done some more research, looks like the fe-c thing is wahoo kickr related.

Anyone else any ideas