ERG mode with Tacx Neo don't work with last update


(Tom Wallner @ ZRG) #62

Is there anybody where the App is working well (with resistance controll…)? Perhaps a reset of the Smartphone and a complete reinstall is the solution.
Does anybody know, If there is a possibility for a reset of the Neo smart. Perhaps a stored BLE profile is the problem.


(Ahmet Yetkin) #63

Yes, Vincent! As I read all posts, understood that perhaps none of us rookie about zwift! And problem is same, resistance.
It is sometimes exact; within the range of just 2-3 watts of target watts (workouts), and feel the climbs ( erg off), and sometimes doesn’t resist enough.
Last week, as my experience, it totally didn’t work, I emailed to tacx support; they told me they couldn’t calibrate third party applications.
But the day before and yesterday it was fine, just in a rest session of 90 watts, it didn’t stay in target range.
By the way trainer worked well with ıt’s tacx app. exactly.


(Yanick Desrosiers) #64

Same here with my tacx Bushido and pixel2 ! Notice that happens when I’m going up or down with high incline, the resistance didn’t change after!


(Hermann Moser) #65

I have the same problem with my Tacx Ironman Smart Trainer (similar Genius). Since the last update there is no control of the resistance possible.

Before the update all works very very fine :wink:


Cycleops magnus resistance
(Vincent W.) #66

Hey everyone, our Android team is investigating Tacx resistance issues. Are you all experiencing the same type of issue with the newest update?


(Chri ) #67

Hallo
Tacx flux…
Huawei MediaPad M5…
ERG-Mode funktioniert nicht richtig! Wenn Ich jedoch aufhören zu treten, wird der “ERG-Modus vorübergehend deaktiviert”, was ebenfalls in Ordnung ist. ODER??
Beim Anfahren beginnt der ERG-Modus jedoch nicht mehr!


(Cédric Richard) #68

Hello, there was an update on January 9th; someone to test to see if it solves the problem?


(Ben Locke) #69

Yes. It seems pretty clear here the latest update has rendered zwift completely useless for us Tacx users. Would appreciate a time frame on the fix as things were working seamlessly prior to the update so should be a simple roll back.


(Michael Tucker) #70

It’s not just Tacx users, it doesn’t work on Cycleops Magnus either. I wonder what smart trainer it actually does work on if any?


(Dimitar Marinov) #71

I am looking at Google Play and I see update only for the companion app
(with the informative commit message: “Bug fixes and improvements”).
Otherwise I did Tour de Zwift stage 4 yesterday and the same issues
continue for me: I did a warm up ride on Volcano Circuit with resistance
control working and then when I got transferred for the event the
controllable was not changing resistance (although still being connected
in connection window).

Is there an update for the Zwift app itself?
Is it just not yet pushed for my region?

From Google Play:
Zwift App - last updated 21 Dec 2018
Zwift Companion App - last updated 8 Jan 2019


(Brand One) #72

I am still experiencing the same behavior.


(Kevin Cooney) #73

Hey @Vincent any chance of this problem being fixed soon it is ruining the experience for me and I can’t use my neo I zwift otherwise. If it can’t be fixed soon I’ll have to cancel my subscription and move to trainerroad


(Vinko Zaninovic) #74

Same thing with, everything was fine untill 5 days ago. Now no resistance whatever i do (reinstall etc.). Using Huawei m5 tablet and neo smart.


(Ahmet Yetkin) #75

Yes, I read All posts, whole same…


(Ade Taylor) #76

Hi,. Using a Tacx flux and a Huawei p20 lite phone, been having resistance problems since the December update, sometimes works ok for 25- 30 minutes other times 5- 10 minutes or not at all. I’ve tried reinstalling Zwift or force stopping the app and reconnecting everything. Again works ok for a while then drops out again.


(Vincent W.) #77

Hey all, a few follow up questions that will help us out a lot:

  • Did resistance work at all? Beginning of the ride, and then after? Is it inconsistent?
  • Firmware versions of your Tacx trainer?
  • Tacx Neo or Tacx Neo 2?
  • Did this recently break?

(Kevin Cooney) #78

Resistance worked for me for first couple of minutes then gets stuck at a certain resistance usually in the lower interval resistance normally breaks after the warm up interval. I am using the tacx neo and this only started happening in the last week. I am using the up to date firmware.


(Alain Badoux) #79

Same trouble with Smart Bushido (TACX). Last version for firmware and Android App (Huawei Pro P20). Resistance seams to work well a few second at beginning and after these few second the resistance not change ever. Sensor for cadence, Power and Speed work well.
It was working well with the previous version of the app.

Thanks for your analyze and as all I’m impatient to have an update to revover the situation.


(Ben Locke) #80

At the start of a session the resistance seems ok but within a few minutes it disappears. I’ve tried a few sessions (erg workouts, SIM, races) and experienced the same problem each time but don’t have the time to waste repeatedly trying any more until a fix is confirmed.

I’m on a Tacx Neo running the latest firmware. It seems quite clear this issue has appeared off the back of the last update with everything running seamlessly before.


(Artem Krivopolenov) #81

Same issue here. Latest Android version (v 32 - 1.0.32519). Tacx Neo is connected.

Quick 10 min ride was ok, uphill resistance was working.

I started the “Zone Benchmarking” workout with ERG mode on. First warming up part was ok, power was being increased from 65 to 145 Wts. Then on the Z2 part with target power = 180 Wts, trainer was showing ~145 Wts, doesn’t matter how hard I was trying to push, power was being decreased to about 145 Wts. Same was for Z3 zone with target 210, average trainer power was ~145 Wts.