ERG mode with Tacx Neo don't work with last update


(Eric Barbour) #42

Same issue with tacx vortex and samsung galaxy S9

Seems to work fine with PC application - just the mobile app


(Rune Fjelldal) #43

I have the same issue. No resistance on my Tacx Bushido trainer since the last update for Android. I’m using Lenovo Tab 4 10 Plus.


(Ahmet Yetkin) #44

Same as before…
Tacx vortex, Xaomi Mi8😐


(Dave Denness) #45

Hi, Same/similar issue for me with S8 and Tacx Flux. I am new to Zwift so can’t comment or earlier versions. In workouts trainer resistance doesn’t change so I have to change gear/cadence to increas/decrease power. In Tour de Zwift keeping steady cadence with same gear my power didn’t change in response to gradient changes but my speed did.


(Tom Wallner @ ZRG) #46

In my opinion, this is a well known situation at Zwift development. At this task you will find no answer from Zwift developers. So the error is no error it’s a feature.
Sorry, but if I start my training with Rouvy, I had no problems like this.


(Ian Macaulay) #47

Same issue for me but with a Tacx Flux and tried with both a Pixel XL and a Huawei M5.
I have spoken with zwift support via email and it appears to be a known issue which is being worked on so hoping this is fixed ASAP.


(Vincent W.) #48

Hey all, Ian is correct this is an issue that our Android team has been investigating and working on. Please let us know which Tacx trainer you’re using and which device you’re running Zwift on.


(Brand One) #49

Verizon Galaxy s7
Tacx vortex
Cheap BT heart strap
London

Just tried it for the first time with the beta. I usually use a PC with ant and have no problems with the resistance control. Resistance changes work fine with bluetooth through the companion app.

My BT heart rate strap works with the beta app but doesn’t work with the companion app on the s7, however it does work when I use my old tablet (Galaxy tab3)


(Benjamin Nicholls) #50

I’m getting the same issue


(Ahmet Yetkin) #51

Same problem for two weeks


(Tom Wallner @ ZRG) #52

Same discussion here: https://forums.zwift.com/t/erg-mode-with-tacx-neo-dont-work-with-last-update/


(Ahmet Yetkin) #53

Any solution?


(Vincent W.) #54

Hey all, looking into this. Everyone is paired to controllable as well right?


(Tom Wallner @ ZRG) #55

I’m already connected with controllable without success.


(Mike Ranger) #56

Yes, that is correct. On the connection screen, it shows paired to controllable, yet no resistance chages ingame.


(Tom Wallner @ ZRG) #57

My question is: what kind of data will be synchronized from the PC’s configuration? Perhaps there are corrupt or false information for a well working Android App.


(Ade Taylor) #58

Definitely says controllable trainer connected, works sometimes for first 5- 10 minutes or a bit longer then stops. If I stop the ride force close the Zwift app then connect Tacx flux again it works again but only for a few minutes. Plus night time screen is too dark and the workout screen is red!


(Brand One) #59

Yes, control and power.


(Dimitar Marinov) #60

I am experiencing the same problems since the recent update.
The controllable is dropping and not changing resistance.
The odd thing is that I cannot reproduce the issue every time. While
it consistently keeps dropping in group rides, I was able to complete
a full day with everything working ok for workouts and free ride.
I completed Jons’ Short Mix workout in ERG mode, and then successfully
transitioned to Sim mode for a hill climb session - no issues.
But next day it dropped 7 minutes into a group ride.
When I close Zwift app and restart BLE connections its back to
working but not for long. Its been 5 group rides/races with it
not working or dropping.

I read the whole iOS(resistance issues) thread and tried all suggested
solution there, but with no success.

Also I noticed that adjusting the trainer difficulty slider from a
non zero value to another non zero value has similar effect.
The controllable immediately stops changing resistance until the
Zwift app is restarted.

Setup:
Tacx Flux S - 3.1.22 / 0.4.3
Tacx HRM Strap -
Samsung Galaxy S9 - API level 26

Environment:
Wi-Fi router in next room (about 7m away)
Laptop and Speakers with Bluetooth switched off (1m away)
Garmin Watch with Connectivity switched off
Wall Power Socket (1m from trainer unit)


(Daniel Styler 7532) #61

I’m experiencing the same problem with Tacx Neo and Samsung Note 9. Sometimes resistance will work for a few minutes, sometimes not at all. Definitely paired as controllable so not sure what the issue is