Erg mode not working (training rides)

Hello fellow-zwifters,

I have an issue with the training rides on Zwift. For some reason the erg mode does not get activated. I have spent the entire 60 min training ride with out Erg mode getting turned on.

Can any one suggest a solution?

-AP

What trainer? How are you connecting? Are you connecting as controllable? Have you ever had erg mode work?

When you say training mode you are talking about a workout yes?

2 Likes

Hi Ben,

Thanks for the reply. I am using a wahoo kickr. It is connected to the Zwift app on my Apple TV via the companion app on my iPhone.

I have used the workout modes several times in the past (as recently as couple of month ago). I never had problems with erg mode in the past. Occasionally erg mode with deactivate and will reactivate with in seconds. But right now it simply does not engage at all during the workouts.

Regards,
AP

I should also add that all my apps (Zwift on Apple TV and Companion app on iPhone) are fully updated and current.

I have heard that ATV problems can often be overcome by ensuring you properly quit the app each time or restarting the ATV before or after each zwift session.

On the companion app there is a button during workout that says ERG on/off. Are you aware of this button and have you tried pressing it?

1 Like

Thanks Ben. I have seen the ERG on/off option on companion app. But I have not tried it. I will check it out next time.

Thanks for the suggestion.

-AP

I just realized that the erg on/off button disappeared from my companion app.

Make sure that it is paired as a controllable and not just a power source.

I read that someone once couldn’t see their erg button because they played with the pref.xml file (setting erg to off) however I don’t think that can be done on ATV.

1 Like

Thanks Ben. Just realized that “controllable” was not getting automatically paired. Fix it. Now the erg mode works.

Thanks again!!

1 Like