ERG mode not available on Apple TV


I am using Zwift on Apple TV with 2 separate user accounts.

Lately when trying to do a workout the ERG radio button on the workouts is not showing on screen and ERG will not control the workouts.

I have removed the app and reinstalled it and it fixes the issue for the first time you use it. When you log back in the next time ERG has disappeared again.

Is anyone else having this issue?



Hi @Martin_Lambe

welcome to the forum.

Do you pair the trainer as power source and controllable?

Yes I use the Zwift Companion app to pair up and control as I am also using a HR and cadence sensor and the Apple TV does not cater for that many Bluetooth connections.

Hello Martin, 2 weeks ago the ERG button /option disappeared in my Apple TV APP and the spindown option as well.

Still I hadn’t got any reply from Zwift about to fix this problem.

Do you have any other reply about this issue?


Hi Marcelo

There are two of us in the house using Apple TV for Zwift both with Wahoo Kickrs. In the screen where you select your power source once you select the power source the ‘Controllable’ box was also automatically selected. This is still the case for my wife but not for me. I noticed this and now when I select the Power source I also need to go into the ‘Controllable’ option and select the Kickr there also.

I am using the Companion App as I have three bluetooth devices. ERG seems to be problematic with the Apple TV. I tried doing a workout earlier today and even though it was saying it was in ERG mode it was not functioning properly. Used my laptop instead and it worked perfectly. Hope this helps.

Hi Martin,

Thanks for your reply!!

Now when I have to do a workout I am using my iPad and when when I ride in a race I am using my Apple TV but I can feel there power is not working well.
Giving you and example descending from Alpe the Zwift at -12% I am riding at 200 watts. This is not normal !!!
At the end I have to use my 10" iPad instead of my 50" TV

PS. In order to use 3 BT devices I am using Companion too

I hope that Zwift fix this issue ASAP

best regards

Have you tried selecting the ‘Controllable’ box and then select your power source?

Manually check everything is updated.

Same here, on apple tv no tick box in workouts to enable/disable erg mode. Also no ERG button available when cycling and swiping up with the remote to view buttons/actions like cam.view etc.
Used to work well, but have not been zwifting much lately - more tacxing :wink: - so I do not know when this started. Today did a workout with zwift academy and discovered absence of ERG button in the game and no ERG to set the power, so had to find power myself which is a bit distracting if you want to focus on rpm and watts

After setting also the neo as a controllable trainer in connections startup menu it is solved… I’m sure I did not have to do that in the past