Erg mode missing after last update

Anyone have had The same issue since last update. The ergmode radio button simply just missing when choosing training. The ability to adjust resistance in the companion app is also gone.
I run a desktop version on a windows 10 computer an companion from an iPhone 12

Hi Kim.

I assume that you did not pair the trainer as controllable. But we will need more information about your system and trainer.

I haven’t done anything else than I usually do in terms of connecting my home trainer to my computer. I have a Bluetooth ant+ dongle in my PC and everything normally connects automatically. I have a heart rate monitor belt connecting to my compagnion app which then connects to the PC dongle.
I have an Elite Direto home trainer
Could you please elaborate about connecting as controllable


Why don’t you just connect your HR to the PC. If you use ANT+ the make sure to use the FE-c option.

The “Controllable” connects when Zwift start up marked “green”
The “Power Source” and “Cadence” connects when I start then companion on my iphone marked “Red”
If I strap my heart belt on this connects with the companion app as well.
Is this a wrong approach ? I has never been a problem before

There are more problems on different bikes with teh ERG mode. Hopefully Zwift or the bike manufactures resolve this software problem.

It think a better way to connect is to connect everything directly to the windows Pc. Unpair everything and select the ANT+ fe-c option for Power cadence and Controllable. If your HR sensor is ANT+ I would pair it as ANT+ aswell.

With ANT+ on your PC you should not need to pair using the companion app.

This problem you refer to, has that anything to do with the latest update ?

Yes we discovered that since the last Zwift update, something has changed in the way Zwift communicates the ERG mode to trainers. Since that update, Zwift only sends a new ERG value when it changes, instead of eg every second.

Ok - Thanks
Do you know if that is something that is being looked at ?

I hope that Zwift also knows about this problem that multiple trainers have problems now.

I am new to this forum.
Is Zwift looking at this forum are do we have to submit this problem?

Problem is known

I tried unpairing everything, removed the dongle. Restarted my computer, paired and plugged in the dongle and suddenly erg mode was available again.
Haven’t seen any update from Zwift so maybe it’s worth a try.