ERG Mode Missing - Is this still a known problem?

Greetings all.

After much trawling through threads I am still trying to find out if the missing ERG mode issue a while back is still a problem.

I have been away from zwift for a few months and my previously working ERG mode no longer works after a game update.

From reading various posts and reply’s from support the ERG mode is supposed to be on by default and is also accessible via the action bar and/or companion app.

I can confirm that it is not on by default for me and that I don’t have the option available in either the action bar or the companion app.

My trainer, which is an Elite Direto is connected via ANT+ FE-C as a controllable trainer and while doing a workout previously would automatically adjust the intensity as required while I maintained my cadence - as I would have expected. That is no longer the case and I have to ramp up through gears/cadence to get to the required wattage.

I have a support ticket open but would be interested to hear if you guys have any input.

Cheers.

Hey Fez, in case you haven’t been contacted already by support, is your ERG mode missing from workouts/training plan? There is no ERG mode in Free Ride.

Hey Vincent.

Thanks for the advice but I can confirm it doesn’t appear in a workout. Oddly, it is turned on in the prefs.xml file for zwift but it definitely does not work in game.

The ERG mode button doesn’t show in the action bar on the bottom of your screen?

If so can you provide a screenshot for us?

1 Like

Fixed.

I don’t know why, but deleting my ANT connections and then re-scanning and selecting them again seemed to do the trick. Bizarre!

Anyway, thanks for your help.

I had the same problem. I performed a re-calibration of my Kickr which fixed the problem.

I have two issues with the ERG Mode
(SetUp: PC:Windows 10 connected by Elite ANT Stick to Elite DIRETO)

a) The ERG Mode is missing in the workout occasionally. Restarting Zwift and Trainer solves the issue to 75 %, maybe less. I usually reboot my PC before riding. I have noe clue where to calibrate the DIreto.

b) ERG Mode i lost during the ride. That usually happens when I stop during the ride. Then the display shows “Steigung” (Ascend) instead of ERG-Mode. It recovers hardly - but somehow I have the impression that it does not recover in intervalls ie. SST (MED) high/low but it recovered in the change from the last low intervall to cooling down.

Any suggestions?

BR
Dietmar

I am also having erg mode issues with my direto. I am using an Apple TV 4 th gen. It worked fine for a year then all the sudden I can’t do any races as soon as I enter starting pen resistance drops to zero and after start of event won’t go up so ill be spinning a 50/11 at 110 rpm for 80 watts

Same issue here. ERG mode on my Direto is no longer working in the workout of yesterday and today. Although the root cause is not clear to me, it might have something to do with the order in which I powered on the equipment yesterday. Yesterday I was in Zwift without power on my trainer (while usually the sequence is the other way around…switch on the trainer and than Zwift). Have to do some debugging…

Hi Dietmar,

You can calibrate the Direto via the phone App of Elite (and also in the MyELite program on your PC another option is via your bike computer). As far as I know it cannot be done in Zwift (unfortunately). In the Phone App it is called “Zero Offset”.

Maarten Hoeks (NL)

1 Like

You could be right. Today I started Zwift and forgot to power on my trainer, so I turned it on while Zwift was already running. Guess what? In the middle of the workout ERG stopped working. This might be something to keep in mind. Next time I’ll power up my trainer first, as usually.

This is the exact problem I am having now on my Directo. Appears to be a “thing”.

“Use ERG mode” is not appearing, and it feels as though I am doing my workouts in NON ERG mode (the trainer does not “bite down” when cadence drops).

Have been waiting on a reply from Zwift and Elite. Will try @Fez fix by deleting and rescanning and reselecting ANT connections - but how exactly do you do this? Sorry, sounds like a silly question but I just plugged in the USB ANT stick and it seamed to work automatically.

1 Like

Hey Maarten,

JUst wondering if yo you ever fixed this problem? I am experiencing the same issue on my Directo. I have reintalled Zwift and calibrated thr trainer but “Use Erg mode” still does not appear.

HI Z_man, I don’t have this issue anymore but don’t remember what I did to fix it. I use an external power meter and replaced the batteries that might be the reason. I expect that erratic powerlevels caused by the low battery prevented ERG mode to engage.

Hope you find a solution too.

Maarten

Currently a problem still, on apple tv no erg tick box in workouts and no ERG button in game when swiping up to display actionbuttons. Frustrating. Tacx Neo 2T, apple tv, android companion app (also on c.app no ERG button…
It used to work ok, and I do reset apple tv after every zwift session…

After setting also the neo as a controllable trainer in connections startup menu it is solved… I’m sure I did not have to do that in the past

I am having the same issue with my Directo, all my workouts feel like non erg mode. I drop the cadence and the power drops :frowning:

I really like your style. Thanks a million and please keep up the effective work.