Erg issues wahoo new firmware 3.5.2

I saw there were Zwift issues last year with a wahoo firmware update, 4.2.1, but that must be a different wahoo Kickr than mine as my current version is 3.5.2. Anyway I’m having the same issues folks had in that thread. The issues are that Zwift is not controlling the bike AND my power on zwift is erratic (same effort may go from 120 watt to 200 watt,etc.). The thread went on for 10 months and all I saw was folks downgrading to the prior version of wahoo firmware. Was this issue ever fixed? I’m having it now. I just updated the firmware earlier in the week. It may have been there awhile, I don’t know, I was doing spin downs in Zwift and not Wahoo. Then I read that I should do them in Wahoo so that’s when I learned of the update. I’ve done the things others did in that thread. No one responded on my chat request with Zwift. I’ve checked with friends, posted, and tried all I know to do. I need to train. Zwift is useless as I can’t even free ride as this isn’t working right either. Help please!

Which exact Kickr model do you have? Is yours on the latest firmware according to the Wahoo app? If so, try downgrading.

This should be easier to find out. I don’t know because I can’t find it anywhere after searching and watching YouTube. I bought it in March 2020 brand new in the box. The firmware causing issues from the other reviewers were in a different version Kickr bc our versions didn’t match and my wahoo app says I’m on the latest. I don’t know how to downgrade . I tried following the instructions they used but they didn’t work. For example they said tap 10 times and that didn’t work - I couldn’t pull up earlier versions, only my version.

Here’s all but the V5

And the V5…
image

You most likely have the V5 given they have been out a fair while. They came with suction cup type feet to add a bit of bike movement. Plus the V5 has the physical connector socket next to the power for ethernet connectivity …

I think I have the 18 bc I don’t have that Ethernet connection. Thank you for this!

1 Like

Actually mine looks like the 14 but with a gray handle.

Actually mine doesn’t look like any of those!

It appears I have some type of hybrid. It looks like version 5 but without Ethernet connection and without the new feet. However it evidently runs on version 18 firmware. The current version for 18 and my Kickr is 3.5.2.

Hi Caroline! I’m sorry you have run into this issue, but we are here to help!

After taking a look into your account, I found that some of the times you have been riding the Wahoo Kickr was not paired to the “Controllable” pairing. When pairing, double check that it is paired to controllable to prevent these kinds of issues in the future!

If this is still occuring after checking this, let us know and we can take a deeper look into this for you!

Update . Working through Zwift support via chat, I downgraded my firmware to 3.5.1. Success!!! Tried a TP workout and Zwift controlled resistance! Evidently 3.5.2 only turns your blinking lights off if flywheel is still for 15 min. No biggie for me as I unplug after use. But I learned I have a hybrid model wahoo. Who knew.

1 Like

Every time I log into Zwift I ensure everything is paired. See my response. I had to downgrade the software. That worked.