Kickr Core Controllable Issues


I’ve got a 6month old Kickr Core, And has worked perfectly up until now.

I’ve had about a month off the trainer, jumped on yesterday logged onto Zwift and into a basic workout.

The trainer now has no control over the power in ERG mode, so its asking in the warm up for 90watts and I can peddle normally into 200-250 watts? ERG used to keep the resistance at the 90watts no matter what gear ect ect…

Logged onto Sufferfest tonight same thing on there…

I’ve got the Wahoo as controllable unit, cadence sensor and also power meter all link via ANT+

Is the trainer broken? ANT sensor for the laptop broken?

Im on the latest 1.0.12 on wahoo app…

It also could finish a spin down either, it got stuck on the final “Spin down part”

I did notice, I can peddle and stop and it takes 5 seconds or so before the computer see 's I’ve stopped peddling and also its telling me I’m putting out 95watts or so without actually peddling for about 10seconds or so.

Any help would be great, do I need to contact wahoo or is it something I can resolve?



Since you had the issue with both Zwift and Sufferfest it sounds like it’s your Kickr.

What did you use to try the spindown? If you didn’t use the Wahoo Utility app then try that and see how you go. I had an older Kickr that kept playing up in terms of the resistance in erg mode and the factory spindown resolved it.

If that doesn’t work I’d contact Wahoo support.

I have a somewhat similar issue in than my Kickr Core will will suddenly get easier to pedal (i.e. reduced resistance) while showing increased power output. It happens in both Erg and Sim modes. I do not Sufferfest, TrainerRoad, or another app to test it in, and did not spend a long time in the Wahoo App to verify it over there.

Nonetheless, after working with Wahoo customer support, they think there is an issue with the optical sensor (which detects flywheel speed) or the reflective tape. Ultimately I’m getting a replacement trainer.

I recommend you call work through the troubleshooting steps on the Wahoo site and call customer service.

I had issues with Firmware 1.0.12 and downgraded to Firmware 1.0.10 and the issues are gone.

It was connecting to Zwift, but displaying “No Signal”

Did you try downgrading the firmware?. Wahoo seem to be ignoring the issue as they are trying to tell me its a bluetooth interference problem, when clearly, one firmware works, one doesnt.

Hi Guys

Thanks for some feedback on this one.

I’ve been in contact with the Wahoo service team (Via “raising a ticket” or something similar on the wahoo web site)

Very quick response saying it sounded like interference from another “controllable” source and to “Forget” the wahoo from the wahoo app, unpair the trainer from Zwift and any other linked bluetooth units. Then repair with Wahoo app perform a spindown and all should be good.

Done all this performed the spindown, spindown finshed as it should. Re launched Zwift on the Mac and repaired everything through the ANT dongle so the connections are FEC connections…

Still no resistance from the trainer, started a workout asking for 90watts on the warmup and i’m able to pedal past the required 90watts easily onto 150+ watts…

It all seams to link as it should but Zwift doesn’t seem to be talking to the trainer…?

Regarding Down grading the firmware is that easy to do?? I’d happily give that a try…

I’ve also started using Garmin Vector pedals recently but these arn’t linked to Zwift or the Trainer so i dont think there causing any issue’s?

Hi Clive

How would I go about downgrading the firmware, The Wahoo App just said there was a update (Coinsidently when the trainer stopped working) so i updated.

1 Like

Hi Johnny
I got the same response, when I said their help didnt work, they then said Bluetooth on Windows isnt recommended and to use Ant+, which I think is nonsense, nowhere in their marketing that I can find does it say that.

Have a look at this thread

Different instructions depending on whether you are iOS or Andriod.


I got an issue with the setup after updating the rollout from 1.0.10 to 1.0.12. I succesfully updated the Kickr Core firmware using Wahoo Utility.
Zwift was unable to connect succesfully to the Kickr Core, it didn’t register Watts, and lost the controllable function.
After several attempts to roll back, this did the trick:

  • Close and reinstall the Wahoo Utility app.
  • Disable Bluetooth on your other device (I run Zwift on my laptop).
  • Tap 10 times on the Bluetooth + Kickr Core logo.
  • Tap on the just opened list of available firmware and tap on the 1.0.10 version.
  • Rollback the firmware.
  • Place your phone/tablet with the Utility App close to the Core, let it download and flash the rollback firmware.

I hope it helps you as id did with me.