Wahoo kickr bike issue after update

Last night I did the kickr bike and wahoo apps update, its the first time I have done this after purchase.
I change the group set to 46/30 11-30 which same as my bike, and go for the Alpe du Zwift, found out that when I using 30-30, in 8% gradient , with cadence 85 I can only do 85w, thats way out from realistic.

Then I change it back to 50/34 11-28, which is the default setting for Kickr bike, before I can do 180w on the 34-28 in 10% climb, now it became 75w in 80 cadence. ( It feels like the game did not give any resistance, but when I use the six or seven cassette , everything just fine.)

And also I find out a situation never happen before, if I stop, both flat and climb, I re pedal again it will give a very very hard resistance, and it did not shows any power in the game, the power shows after 1-2 seconds when the resistance drop…

I have try many ways to get the ride feeling before update…trainer difficulty are set 100% for show cuz the wahoo apps shows the exact same gradient.

Thanks a lot :pray:t2:

I asked the local bike store, seems I am not the only one experience this…

What version Kickr Bike firmware?
What version Zwift?

Kickr bike firmware 1.22.0
Newest Zwift version and newest wahoo apps

Yes, same here - regardless of gearing.

I could start off from standstill in the 2/9 gearing with no problem at all. I had more resistance downhill than uphill.

Resistance is only moderate and doesn’t reflect the gradients.

Also 1.22 firmware. It’s disappointing

@shooj - any ideas?

This is why I haven’t upgraded the firmware on my Kickr Bike. But the thing is very nearly useless in Erg mode during workouts. I have to ride in top gear and even then I ride at the top of my cadence band to keep the power numbers up. Granted my top end of cadence is >125 so I can sort of make it work but nearly every workout has the “Spin Slower” banner flashing the entire time.

Suggestions?

I found the way to downgrade firmware that works, in the wahoo app you have tap the bike icon very fast. Not ten times, but tap it multiple times really quick then it opens the hidden firmware screen.

Very bad design Wahoo! I’ve downgrade to 1.16 and hope it is better. Seriously, this is not what we pay AUD$6000 for.

Edit: this downgraded firmware was much better. Everything is working normally.

3 Likes

I had the same problem. I tried the Ven-Top ride and found I was in gears 2/9 on a 12% grade and only putting out mid 100 watts. I knew something wasn’t right as those are the gears I use when racing a flat course! I dropped to 1/anything and just practically spun freely. I gave up and did a training in ERG mode that worked fine. I backed out to the previous firmware. My Wifi went down so I can’t test it, but I hope that fixed the problem.

Thank you! I backed out to the previous version (never would have figured out how without your help) and it works fine now. And for some crazy reason I was looking forward to the Ven-top group ride. At least I quit after 5 miles of spinning away.

1 Like

That’s great it worked for you. I think Wahoo should really be testing their updates with Zwift to find these bugs rather than using paying customers as test analysts.

With the 1.22 firmware even the climb feature stopped working correctly.