Elite Turbo Muin and Elite Misurio B+ How I got it working after a month of stress

After raising to support tickets and getting the same incorrect response from both of them I finally figured out how to get a power and therefore speed output.

Sensors I use in addition to the Elite Misurio B+ are a Garmin GSC10 speed/cadence sensor and a Garmin HRM

You have to follow the instructions from Elite and set the sensor to 12 flashes (for the turbo muin, other elite trainers vary and they are found on the table within the instructions for the sensor)
So on the pairing screen the sensors that were found without having to do anything other than a search were the HRM and the GSC10 and a Elite Real Power sensor.

The Elite Power Sensor is not the one to select 

Go into the Power Meter Sensor search and turn your cranks miraculously a new sensor appears in the list as a generic power meter and you will also see a power measurement in response on this sensor and not and not on the Elite sensor that is listed there.

Select the generic sensor and you should be good to go.
I don’t know why the generic sensor does not appear automatically and needs the cranks turning that’s something for Zwift to sort out. Previously it never appeared regardless of the cranks turning

Hey Darren,

needed to take the time so say a big THANK YOU.

After weeks of stress and disappointment, I found your post, followed the instructions and got the Turbo Muin finally working with Zwift.

Our friends in the Swift Tech Support Team should thank you too and give this solution the visibility it deserves.

Have a good weekend, buddy.

Ride on.

Giovanni

No worries Giovanni, hope others find this as useful as what you did. Ride On

Hey guys. It’s a year since the last post but just wondering how the Elite Turbo Muin Smart B+ trainer has worked for you on Zwift? I was looking at possibly getting one. Thanks.

works fine I’m still using it…

hi,

i use elite turbo muin b+. i followed the instructions to make all setting correct. i’m getting flier speed detection warning every zwift ride. i am bored. i was a monthly subscriber to zwift. i don’t understand where the problem. 

 

Semiiral.

this is for the Turbo Muin with the misurio b+ sensor (which had to be bought separate from the turbo) not the TurboMuin B+(which has the sensor built in). Sorry for the confusion.

never seen that error so I don’t know of a fix.

My misrouted B+ has just arrived and after initial failure looked on here. I’m hoping your fix works Darren. Will report back.

Thanks. Paul.

Hope it works as well for you as for me i’m not using zwift during Summer months but once winter sets in i’ll be back on it, i’ve had zero issues following my method and I think have actually solved the problem now as my issue was nearly 2 years ago. I noticed ast time I was on it came back with Elite Power meter or something similar so it seems the issue has been fixed…you still need to set the sensor to 12 flashes.

Hello Darren,

I could kiss you. After 5 minutes faffing, it works.

Just one question. I’m using Garmin speed/cadence and heart rate monitor like you and now have the thing working with power displayed. i haven’t done a proper route yet but do you get increased resistance going up hill and decreased/spinning when you go down. This is what happened on a previous Tacx trainer with a motor brake I had.

Anyway, just wanted to say many thanks for taking the time to share your fix with us.

Paul :) 

Hi Darren, Big thank you, been trying for 2 weeks to get this set up to work and your fix sorted it. I can ride at last. Thank you for sharing. Nev.

Good to hear Nev, I should be back on Zwift in the next few weeks…I stay off it when the weather is suitable for outdoor riding but we are coming to that time of year, when the light and weather and time constraints force me back onto turbo to train for next season and get my FTP up and to prep for my Mallorca training camp early next year

Maybe see you in zwiftland then Darren, its already that time of year in North Lancashire :wink: Again thank you.