Elite Suito / Direto resistance issue

Alright, I got my first smart direct drive trainer this Monday and it was great. Today I tried to connect it to my wahoo bolt, to see my data not only on zwift, but also on my wahoo. Simple, right?

From here, it all went downhill. If you did the same thing, don’t worry and continue reading, I have a fix for you. I had a problem, that when I started pedaling, the resistance went all out to the point where I could not turn the pedals. I tried to reconnect, unplug… all the simple stuff. Then I somehow fixed with myEtraining app, but now, there was NO RESISTANCE :slight_smile:

After 4 hours of trying literally everything, I tried to do the same thing once again. At first, I unplugged and plugged in the Suito. Connect it to wahoo once again, and delete it, turn off the wahoo, never turn it ever slightly near your trainer (unless you are using kickr I guess). Jump into your myEtraining app, scan the QR code on the trainer, pair it like it is a new one (my circumference when I got it and also 2070), unplug, plug in. Jump on zwift and here you go. Your trainer should be fixed now, with resistance working in a free ride and also ERG in workout mode.

Hopefully this fixed your problem and made your life easier (and saved you 4 hours trying to fix it :slight_smile: ) . Anyway, if this was already posted or is in incorrect category, do what you want with it. This is my first ever post on this forum and I just wanted to share this fix, as I saw this is a common problem with suito and direto trainers. Have a nice day and ride on :slight_smile: