Elite Roteo Power & Cadence Dropout

Zwift is intermittently picking up the data from my Elite Roteo.
Garmin heart rate strap is working fine, so it’s not an issue with ant+.
The smart trainer sensor and ant+ sensor are just a few cm away from each other courtesy of a usb extension lead.
On start up, Zwift picks the power and cadence up from my Elite.
Once I have started riding, the power drops out. It still shows as connected in the pairing menu, but then later says ‘No Signal’.
I try to re-pair the power and cadence to no avail, so I reboot my PC.
This initially seems to work, but the power drops out again and same with the cadence. Then they disconnect and are no longer discoverable.
Meanwhile, the Garmin HR remains connected and working the entire time.
I have tried with a Acer Predator gaming laptop and have the same issues.
Also tried swapping the battery in my Elite trainer.
Has only occurred since the most recent update. Before that, it was working perfectly.
Any suggestions?

Similar problem here. Since the last update, Garmin heart monitor strap stopped working. Used to easily pair with the ANT+ adaptor, but not working since last update. Other friends having the same issue.

Zwift support suggested the following:

Here’s what you’ll need to do:

  1. Exit and close Zwift. Make sure Zwift is closed from your taskbar (Windows) or your dock (Mac), as well.
  2. Open the Documents folder on your computer.
  3. Open your Zwift folder.
  4. Delete the files named prefs.xml and knowndevices.xml, then close these folders.
  5. Launch Zwift again and pair your devices in the correct spots on the Zwift pairing screen, then go for a ride.​

This kinda seemed to work. The Elite Roteo/Volano is now discoverable, but will not work with the Misuro B+ sensor being on the 14th blink setting (like it says in the elite manual).
Instead, it only registers power and cadence data if I switch the sensor to the 13th blink setting (for the Elite Muin).
Zwift pairs no problem with my PowerTap PowerCal He/Power Meter, so there’s no issues with Ant+, cables or any other interference. Even changed battery in the Misuro B+.
What’s even stranger, I booted up rival program Rouvy. Works perfectly, so it’s definitely something to do with Zwift.

Gets worse. Zwift support now claiming that the Elite Roteo is a ‘classic trainer’ instead of a direct drive smart trainer.
Just to reiterate, I had zero issues with Zwift prior to the most recent update.

  • deleted, not relevant for roteo -