Elite Qubo Digital Smart B+ Flat Resistance is Off

yes. With the infrared off, you have to make several turns of the axis. If he doesn’t, it is blocked and you have to help him with a pliers.

1 Like

https://elitesrl.zendesk.com/attachments/token/5roJR59WOCtz2u52zlAT6aBcc/?name=Sbloccaggio+stepping+motor.pdf

1 Like

Thx Salvador, I used the pliers as you mentioned and now it turns automatically when I put the power ON.

Now I think that the only thing that I have to do is to try it, right?

Yes.
it sure works now.

I have the same issue (connect to my 2011 macmini with bluetooth). My Qubo smart it’s too hard on flat, I’m faster riding on hills than flat!
At the beginning it works fine I believe (first two rides), after install Zwift Companion apps and create meetings started the problem. I don’t know if there is some relation.
I’m waiting a ANT+ stick and I hope it fix it or they fix the issue by release.

1 Like

Hello !
I connected the Ant + key and chose FC- for watts, cadence and controller which was recognized immediately in Zwift.
The roller resistance worked well in the ascent of Innsbruck until the middle of the descent.
The resistance jumped and then no longer worked.
I feel I loose it at 92 km/h (so over than 500 watts) wen I ride in middle of a group…
I reconnected again twice but without success.
I try again today…

After a week and a half of frustration, connecting, downloading, uploading, disconnecting etc got one good ride in yesterday. Sorry no miracle answers because tonight now I can’t hit 100watts at 20kmr on the flats standing on the pedals in my smallest gears. So now I have ridiculous resistance. Either zwift or the elite trainer as soon going in the bin.

Are you sure that the mechanical “trolley” with the magnets can move completely from the right to the left?

I suggest you to:

  1. remove the plastic cover from the elite qubo
  2. power on
  3. open the my Etraining app
  4. execute a training
  5. move the flywheel emulating you are cycling
  6. the “carriage” with the 2 magnests should move completely from right to left and back

When you stop the training, the Carriage should move again.

If this works properly you can completely exclude a mechanical issue with your trainer.

Hope this help

1 Like

Thank you Salvador,

I just bought a second hand qubo digital smart b+ and have had this issue. Tried your method and that’s it working! Thanks!

1 Like

since that easy repair I have taken more than 500 km without problems. Greetings

Iam having the same issue. It’s not the trainer because it works perfectly on the Elite My-Trainer app. It’s just when I used zwift, with a flat tire problem included in my case :confused:

Any update to fix this problem?

Hi Salvador, it is me again. Recently I got the same problem like you that the shaft is locked… I used your method & it is freed now. I wonder what we can do to properly maintain the trainer so the shaft won’t lock again. Wonder if it is a good idea to oil the thread of the shaft or the plastic moving surface (saw some oil residue there) ? Any thoughts?

Hello all, I have the same issue, I turned the shaft 3/4 and when I turned the trainer back on, it rotates back to the “locked” position and then seems to stick there again. I can see the trolley is moving originally but then I need to loosen the shaft again because it seems to always get stuck in its original position

I had a similar issue with my Qubo Digital Smart+ suddenly not providing resistance in the middle of a ride . That gave me an unearned ability to generate massive power according to Zwift. I sent an email to Elite’s Customer Care. They walked me through several steps to try to repair it it, but my shaft never moved. They shipped me a new magnet cart that I was able to replace myself and it is running well now… (No more first place segments for me, though!)

1 Like

Great help in this topic! Solved it (also with quick support by Francesco from Elite!)

how did you get a new magnet cart? mine is broken too, do you have that email? i cannot find one anywhere

yh i have the same the trolley gets stuck on the hardest resistance, i think the thread on the cart has gone

Adrian,

I emailed Elite’s support at myetraining@elite-it.com. They shipped the magnet cart and emailed some instructional videos on how to install it. They did have me do several tests (also through video instructions) first to rule out any other problem. The Elite team was very helpful.

Alan

1 Like

Alan, thanks, that is brilliant news, yes i have emailed them too, fingers crossed. Adrian

I tried France yesterday for the first time and set off on my Elite Suito connected via Ant+. It had worked seamlessly before but yesterday the resisitance stayed high during the entire ride, not changing at all and remaining high even on 7% downhills. Does anyone know what might be causing this and how to rectify it please?