Elite Axiom Wireless trainer avatar doesn't move

Hi all,

I have an issue with not moving avatar and no power when I am in virtual world. During trainer pairing everything looks correct watts are showing but when I click ok and I am deplyed into map avatar is not moving and watts are not showing. And after that when I return onto pairing screen and start pedaling power source still shows 0, if I unpair and pair again situation repeats. Please see pictures.

Did anybody face same issue?

Iam running on Elite real Axiom wireless version connected on windows laptop by ant dongle.

Thanks for help

Same so frustrating problem here!
someone told me to check the firmware of the trainer if it’s up to date…mine unfortunately isn’t upgradable…I likely have to find a different solution than my trainer (an Elite Real Tour)…

@Matej_Sramko and @Damiano_Fusari welcome to the Zwift forums.

The Axiom Wireless is not listed on our list of supported Elite trainers. It’s likely your Elite model was made prior to the standardized flavors of Bluetooth and ANT+ that are in use now. So while it may broadcast a BLE or ANT signal, it’s probable that it was designed to work with Elite’s own app, not with third party apps like Zwift.

I tried to search for the Axiom Wireless on Elite’s own support forum, but all mention of it has been removed. I would like to be more hopeful, but I don’t think it’s going to work.

An inexpensive workaround is to buy a crank-mounted speed sensor that brodcasts in Bluetooth LE or ANT+ such as this one made by Wahoo.. This basic setup will allow you to pair to Zwift.

I don’t think so, because zwift wont know at what resistance you are riding. Except if Zwift has a power curve for the trainer if it is unplugged.

You know what? @Gerrie_Delport is correct about the power curve for an unsupported trainer. It’s not going to be great riding experience with your speed not being correct.

1 Like

Thanks for reply fyi I am posting screenshot that is saying that zwift should support this trainer.
On other side I did tried to run it through external speed senspr as well but during climbig it shows unpropriate speed 1kmh or so which is frustrating as well.

When you paired it as a power source, what options did you see. click on unpair and the click pair and see what options you see.

Post a photo if you can.

Elite has so many different trainer flavors it is hard to keep track

@Matej_Sramko
Where are you seeing this image?

I assume here, https://zwift.com/hardware

I see only one option called real axiom 389 ant+ no other options as power source.

1 Like

It can be that Elite had different versions of the Axiom and only some are compatible.

Yes that sounds reasonable but as a newbie I checked zwift pages before I bought this trainer and based screen shot above I was pretty sure it will work, but when I pluged it I was confused. Now I have to chceck for another trainer.

@Gerrie_Delport
:roll_eyes:

@Matej_Sramko
Looking at your session logs on the server, the trainer is connected as “controllable trainer” and not as a regular trainer

Please unpair the Controllable and see if this gets the avatar to move.

@shooj
I just did but still showing zero watts and avatar is not moving.

This is very strange to me.

I am guessing here:
Can you turn off your laptop bluetooth.
Try a different usb port for the ant+ dongle.

So you were able to ride with the speed sensor, so that confirm that your account is active.

@Gerrie_Delport
When connected through ANT I has bluetooth turned off, for ANT dongle I tried all three available USB ports. As I mentioned when I connect speed sensor through BT or ANT doesnt matter situation is same, avatar is moving but 4-5% climbing is on 1-2kmh speed and honestly based on some practice even it is calculated throug different patterns it should be over 10 kmh for sure.

1 Like

Yes the speed sensor is not a good option.

And did you try to only pair as power and unpair as controllable.

Does your power go up an down in the pairing screen if you pedal faster and slower.

Unpair every thing, and select just watch. Then when you are standing there press “A” and pair only as Power Source and see if that work.

Sorry, I am trying my best to give you some ideas.

1 Like

Thanks a lot Gerrie, yes I did try as only a power source without anything else connected situation is same while pedaling on pairing screen power goes nicelly up ond down based on pace, but when I click into the map/world power is still showing 0. When I look back on pairing screen power is going up and down as it should be when everything is unconnected, when controllable is connected power is showing 0 as well on pairing screen, to make it working again I have to unpair it and pair one more time.

I will try your suggestion on the morning as now we have 2 am so time to sleep :grinning:

Thanks for now

1 Like

Good night.

I am just jumping in on this, I has the exact same trainer and the exact same problem.

I has run 400km whit that trainer a year ago and stopped, now I want to go back on. The setup is exactly the same, same trainer, same computer, but Zwift has Ben uninstalled and reinstalled.

I has now tried 3 diff. Pc and to diff ant+ dongle.

And same story.

So the trainer did worked on zwift but don’t know if there was something special in one update in some time.

I tried to install the elite program and I worked whit no problem there…

A little note is, when I am in the parking screen and pedalling ex. 9w and go for the ride it take that 9w in to the ride, but the avatar is grounded and doesn’t move.

WHAT TO DO😩