Elevation not syncing with resistance on my Wattbike Atom [August 2022]

@shooj are you exclusively looking at Mac users here as I have identical problem with PC and a Wattbike Atom. The bike is new so don’t know if it is a long standing issue or related to a more recent release

For awareness, there was also a new Wattbike Atom firmware drop this week.

You need to know if its Atom V1 or V2 (V2 had firmware update, V1 didnt).

This very issue, used to present many iterations ago on Zwift, seemed to disappear a good while ago. Ant+ didnt seem to have this issue.

@Douglas_Cook
The thing we’re investigating is specifically on macOS, but sounds like we need to look into other OS platforms.

Curious - did you apply the Wattbike firmware update that Lee mentions?

For those weighing in - would you also let us know which version of the Wattbike firmware you’re using?

The issue existed last week with the previous update, have noticed new update available today but not yet tried it. Shall report back!

Updated to latest firmware, same issue exists. Atom Next Gen, Windows 10

I have also been having this issue for the past week, both in ERG mode and in freeride mode. My setup is Wattbike with MacOS.

When doing a workout the erg mode doesn’t work (even though switched on) - I have to use the gears to change resistance. When in free ride the resistance doesn’t change when going up or down hills.

I have a Wattbike Atom and it is running firmware version 1.02.01.

Any help would be appreciated.

MacOS version 11.6.8 (nacOS Big Sur)

@Lee_Godfrey we just made a backend change so your setup should be good to go again. Could you please let us know if you are still seeing this issue after your next log in?

1 Like

WIll do. Thank you

1 Like

One possible workaround for those having this issue.

  1. If you have an ANT+ USB dongle - you might try pairing via ANT as Douglas suggested upstream.

  2. If you are Bluetooth-only - rather than using the native Bluetooth LE (BLE) setup in your Zwift computer, try pairing via the bridged Bluetooth method using the Zwift Companion app. Instructions are here.

With regards to the PC issue which seems to be ongoing. Yes these 2 workarounds work though IMO are not really viable solutions long term. My experience of both Ant+ and the companion bridge is that neither provide as reliable connection, and Zwift’s on recommendation is that native BLE is the preferred connection method.
It would be great to know that the issues on PC are being investigated so we only have to rely on the above suggestions temporarily.

I tried it this evening, both in free ride mode and in ERG mode in a workout. It seems to be working again now. My wattbike’s resistance increased as I’d expect when climbing, and also the power demand changed automatically in a workout.

Thank you very much for responding zwiftly (:joy:) and for resolving the problem.

Lee

1 Like

@Douglas_Cook
We are investigating this symptom on PC / iOS as a separate incident from macOS. We’ll update this thread with progress on both investigations.

@Lee_Godfrey
Thank you for looping back to let us know. We’re pretty sure of the root cause on macOS, and the fix for that will be in a patch ASAP.

2 Likes

Thanks @shooj , let me know if I can provide any more information to help investigations

Hi everyone, just want to add to this as I’ve been having similar issues.

Training on a Wattbike Atom V1 - when in a workout regardless of whether the ERG is on/off, my bike gears don’t respond at all, the app seems to take over and set the resistance without any manual control of my own. This seems to be creating only two levels of resistance for me, either cycling through sand or cycling on air.

When going in free ride control of the gears and resistance is fine though.

Any help?

Unlike the others though this is working on Android OS Version 12, Zwift App Version 1.28.0.

Hey @shooj is there any update on this?

On my side I’ve:

  • Updated again to latest WB firmware.
  • Updated to Windows 11.
  • Run through diagnostic checks with WB.

The issue still exists.

Wattbike are sending an engineer for further checks but seems unlikely they will find anything given others seem to have the same issue.

Update September 6:
This issue on macOS is resolved in Zwift game version 1.28.1. Mac users, please update at your earliest convenience.

We are still working through similar Wattbike symptoms on other OS platforms, and will update this thread as we make progress.

1 Like

Can we add in a few other wattbike atom issues that have been present for a very long time??

For starters…

ATV - End of a workout you can not return to gear mode and are stuck in a single gear until you unpair & repair the device.

Thanks for letting us know, Shooj! will do on updating the client software.