Domyos RUN100E not detected

Hello;

I bought the Domyos 100E that shows a compatibility with Zwift :

My phone detects it in the bluetooth settings. I can pair it to the Domyos app and to Kinomap. But not on Zwift (and I bought it only for Swift…). It’s not showing when searching.

Please help me.

Unfortunately it does not appear to be compatible. In today’s world where manufacturers can put anything on their website it’s best to check the official support documentation:
https://support.zwift.com/en_us/supported-running-hardware-SycvahzDB

It’s like the biggest sport retailer / Equipment maker in France / world.

Did anyone try qDomyos-zwift ? It seems to allow to convert Domyos Bluetooth into Zwift compatible Bluetooth for Domyos runner and bikes…

Tried it with qDomyos-Zwift app. Seems to work fine. I did not find any other way to make it work. Its a paid app for $5 or so on the App Store.

Hi,
I am about to buy a domyos run100e and I have been investigating how to connect the treadmill to zwift.

In the customer review section of the treadmill in Decathlon co uk, a Decathlon associate has uploaded a video showing how to enable FTMS from within domyos econnect app.

My feeling is that the domyos app acts like a bridge between zwift and the treadmill.

This is the comment where the video is shared:

Je vous adresse une petite vidéo pour vous expliquer comment faire et j’espère que vous pourrez profiter pleinement de cette nouvelle expérience :

You can use Google to find the comment, i cannot paste links here :slight_smile:

It would be great if anyone could test this

Dani: I can confirm that FMTS (as shown in the video mentioned in your comment) works with run100e.

1 Like

hi @Roman_Svitanic ,
so i finally bought myself a run100e. and unfortunately this is not working for me…
i do the same as in the video:

  • open econnected app
  • enable ftms
  • kill econnected app
  • open zwift
  • pair treadmill => this is working fine
  • press “start/pause” on the treadmill => the treadmill starts. the treadmill console shows no speed. zwift does not show speed either => in the end my avatar does not move :frowning:
  • in the video the lady also controls the treadmill with the remote. this is not working for me either.

can you give me a hint, if you are doing something else in addition?
where are you running zwift? android, iphone, windows? (i tried both android and windows)

on the back of the treadmill, there is a sticker which says that my treadmill is a run100e-version b.

thank you in advance

Hi @Dani_Pindado,

I just enabled FTMS via eConnected app on iPhone, nothing else. I did this just once when I first installed the treadmill. Since then I haven’t opened that eConnected app again.

Zwift on both iPhone and girlfriend’s iPad runs great and picks the pace from treadmill :slight_smile:

However on macbook, it’s random. Sometimes it works, usually it pairs OK, but after I start running treadmill goes to 0 kph, then if I set some speed again it works for few seconds and then it goes back to 0. So now I run on iPhone and mirror the screen via airplay to monitor.

1 Like

Hi @Roman_Svitanic
Thank you so much for the information.
I wasn’t aware that it was enough to activate it just once.

One question:
Is the remote working for you when on zwift?

And another one :slight_smile: :
Can you see the speed on the treadmill console when on zwift?

I feel now that maybe my Android phone is not activating ftms properly…

@Dani_Pindado:

  1. yes remote is working, but only for 0.1 kph speed increments/decrements.
  2. also yes, speed and pace is shown on treadmill’s display while running on Zwift via BT.

I think that FTMS is activated correctly, since otherwise Zwift won’t be able to see and pair you treadmill.

Maybe you can try to run with Zwift on iPhone/iPad, e.g. if any of your relatives or friends have one, just to find out where the issue is.

1 Like

With the help of domyos support department i managed to connect the run100e to zwift even with android.
Somehow the video was misleading me. The treadmill won’t connect to zwift properly after enabling FTMS. After activating FTMS, one has to power off once the treadmill. Then one can power on again, and the treadmill will connect to zwift.
As @Roman_Svitanic mentioned, FTMS only needs to be activated once. The setting will be stored in the treadmill.

Here the complete workflow to use the run100e with zwift:

  1. open econnected app
  2. enable ftms
  3. kill econnected app
  4. switch off treadmill
  5. switch on treadmill
  6. open zwift
  7. pair the treadmill
    8…run

Steps 1-3 only have to be done once. Afterwards you don’t need econnected anymore

Hi @Dani_Pindado

Thanks for sharing your solution with the community!

Ride On.

1 Like

Much appreciated as the Decathlon store in my area has this model and I am keen to replace my existing XQIAO Q1C treadmill.