Zwift installed on Nordictrac?

Anyone install zwift on a Nordictrac treadmill and make it work with iFit ?

Hey @John_Arias_Global_El , welcome to the forums.

I dont do the Running thing but I’ve seen Nordictrac mentioned a bit around here - hit the search button using that as keyword and you may find what you are after.

@Stuart.Middlecoate is a bit of a run guru around here so might be able to chip in with some help.

Thanks for tagging me in Dean.

John,

Most of if not all of the newer Nordictrack treadmills have Bluetooth integration so they work seamlessly with Ifit which is their own product.

I’m not sure what you are trying to achieve when you say install Zwift on the treadmill and make it work with Ifit.

Do you mean you want to be able to use Zwift with your treadmill?

If so then yes this is entirely possible. Although the treadmill itself won’t communicate with Zwift you have many options.
A footpod, sports watch or the NPE Runn can all send data to Zwift.
However the best way is to use an app called QZ Domyos. You install it on a phone or tablet (not the one running Zwift) and this will read your treadmill speed and send it to Zwift.
And the really good bit is that it can also adjust the incline automatically in line with your Zwift course just like Ifit also does.

The app costs only a few pounds, dollars, euros and the developer is easily reached. I know that the app is compatible with all treadmills that run ifit.

If you need further help let me know what model treadmill you are using and how you run Zwift.

1 Like

I have done something like this, but doesn’t work, but so close.I also did the hack so privilege mode was always on and you can toggle back and forth between apps. I’m still getting the same result. All connects fine. Start the iFit, set a speed, the speed matches on the qz app. Open zwift start a run, the avatar is running at the speed of the treadmill. Increase speed, treadmill picks up the speed, but on zwift it stays the same and the qz doesn’t change. When I toggle back to iFit the screen is white with just the logo showing and doesn’t go back to the manual workout. It’s so close to work. Not sure how to fix or a better solution. Would be nice to watch zwift of the huge Nordictrack screen.

John,

I suspect the issue is that you are running the apps in the background, neither Zwift, iFit or Qz like this.

They all have to run in the foreground. Is there a reason you run Ifit alongside Zwift? Why not one or the other? If you are running QZ with the auto incline this will be working against Ifit.