Does the Zwift Companion App require a paid account?


(Haroon) #1

Hi Zwifters. Sorry to create yet another “Companion App Won’t Work” thread, but I am faced with little choice.

Despite much effort and various diagnoses, I am unable to get the Companion App, on Galaxy Note 8, to connect to an active Zwift session on Mac and thus go into “game mode”. Firstly, let me state that I’m still on the free trial, with a few days left, and would like to try the Companion app before going all out on a paid account.

I have downloaded and installed the Companion App on both an iPhone6s and a Samsung Galaxy Note 8 with the same result. In both cases the app will only show me the Home screen and not the Game screen. I am logged into the Companion app under the same Zwift account as on the Mac and even when currently Zwifting there is no game mode.

The phone is on the same network as the Mac and I have ensured that it is in Airplane mode (per a recommendation here on the forum) with only Wifi turned on. As an additional pre-caution, I have rebooted my router (several times). I have also followed the trick that one forum user reports, namely that by releasing and renewing the lease on the phone’s IP address, he is able to get the Companion App to connect. I have tried the same but to no avail. The Companion app is definitely logged into the correct account as it states that I am currently Zwifting and will show me all my past activities including the current one. But Game mode is never achievable. I’m left wondering whether it’s because I’m on a trial period?? Please help. PS! Thought I should mention that clicking on the current activity gives the message “Activity Unavailable”.


(Paul Allen (Watopia Wayfinder)) #2

There’s is no difference between the trial and the paid version.

What router are you using, it almost sounds like there is some kind of WiFi isolation going on.

Have you tried turning off any anti virus.


(Haroon) #3

Dagnammit… I totally forgot I had enabled AP isolation in the router. That was it, you hit the nail on the head Paul. Thanks for solving this issue for me.