Difference in watt between zwift and zwiftpower

I attended WTRL on thursday. When you finish you get this blue generated image with some watt numbers. Comparing these numbers with zwiftpower it differs a lot.
Zwift had 5min/3.8w, 1min/4.6w and 15sec/5.9w.
When looking in zwiftpower I get 5min/3.6w, 1min/4.2w and 15sec/4.2.
For the 20min w/kg they agree…

Why is this happening? Bug?

Your ZwiftPower figures are using Live data which is not that accurate. Some hours after the race the results are updated to use a .fit file. On ZwiftPower you will notice that all your profile rides show a green lightening bolt on the results line. That signifies that your results have not been updated with the .fit file.

You have your Ride activities set to Private on Companion App. With this setting at Private ZwiftPower does not update your Ride results.

If you wish, I believe, you can test by setting this particular ride to Public on your Companion App, go into ZwiftPower and refresh profile. This may update that particular activity and turn green bolt to blue. If that doesn’t work make your Companion App Privacy setting public and try again. You can always reset Privacy to Private afterwards if you wish.


Ok. Didn’t know about the functionality behind the lightening symbol, so learned something now :slight_smile:

Tried both changing privacy on the specific ride followed by refresh profile, but still green symbol. Tried also changing the global setting to public but no change either. Will keep it public and hopefully the next rides will be better!