Devices Paired But Not Moving

Hi there. I am using the following setup: AppleTV 4K, Viiiva HRM, garmin ant+ cadence sensor and garmin speed sensor 2 on a CycleOps Fluid 2 trainer.

I can get all of my devices to pair to the AppleTV, but my avatar will not move when pedalling.

I can get everything to work if I run Zwift on my phone. I have signed out of everything on the phone and the sensors are not connected to anything else. I have tried the hard reboot on the AppleTV as well.

Please help as this is frustrating. If I try to AirPlay, it’s choppy and I shouldn’t have to do that.

Do you use the same username and password on your phone and ATV? Wild guess is you don’t have an active subscription on the ATV.

I use the same username and password on both devices. I see readings from the devices but I can’t move. At one point earlier today, I could pair the speed sensor but as soon as I tried to pair the cadence sensor and HRM I stopped moving.

The Garmin speed sensor 2 is Bluetooth and ant+ and the Viiiva acts as a bridge for the cadence sensor.

Do you see power readings in the game as well or only in the Paring screen.

No power readings on either screen. When pedalling In game - only rpm and bpm, no watts.