Dell XPS13 9360 Not Responding

Zwift keeps crahing (not responding) on my otherwise good laptop.
I have 16GB RAM, and there are plenty of resources available.
I connect BT devices fine, but have tried using in BT Bridge mode as well, and Zwift keeps crashing.
I tried this on a second Dell XPS 13 and got same error.
Don’t think network problem as runs fine on iPad or Samsung S10 on same network.
I really want to run this on laptop for screensize.

PS: I have done all the obvious already:
Checked that all W10 updates are installed.
Checked latest graphics driver loaded.
Uninstalled and re-installed Zwift.
Close all other running apps and background apps.
Closed AV software.

If anyone has an ideas it would be greatly appreciated.

Can you post the specs of the computers.

Just to chime in here, I had the same issue on my XPS 13 9365 and just got it working.

  • Uninstalled Zwift
  • Checked Windows Update, there was a pending update there for .NET, and also one to update to v1909. I installed that, and re-started laptop
  • Re-downloaded & re-installed Zwift, it went through it’s Update process which took just over an hour

Software runs and picks up all my sensors.

Hi Paul,

Pleased to hear you got it working. I have a different issue in that I can start software and connect to sensors 100%, and even “complete” a ride, but Zwift hangs every 2-3 minutes for a minute or so.

I’m using on tablet, but find the font sizes too small in some places and really want to use laptop/PC.

I have sent support request and hoping Zwift will respond, as we’re paying plenty for this software.

Will revert to Rouvy if can’t solve.

Hi Paul, not sure how much detail you looking for, but below is 1st portion of system information.
I have re-checked updates and not being prompted for any updates.
Hope this helps and you can maybe spot something.
Regards,
Craig

System Information report written at: 04/03/20 13:12:32
System Name: CRAIG-DELL-2018
[System Summary]

Item Value
OS Name Microsoft Windows 10 Pro
Version 10.0.18363 Build 18363
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name CRAIG-DELL-2018
System Manufacturer Dell Inc.
System Model XPS 13 9360
System Type x64-based PC
System SKU 082A
Processor Intel® Core™ i7-8550U CPU @ 1.80GHz, 2001 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date Dell Inc. 2.13.0, 14/11/2019
SMBIOS Version 3.0
Embedded Controller Version 255.255
BIOS Mode UEFI
BaseBoard Manufacturer Dell Inc.
BaseBoard Product 02PG84
BaseBoard Version A00
Platform Role Mobile
Secure Boot State On
PCR7 Configuration Elevation Required to View
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = “10.0.18362.628”
User Name CRAIG-DELL-2018\craig
Time Zone South Africa Standard Time
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 15.7 GB
Available Physical Memory 7.72 GB
Total Virtual Memory 18.1 GB
Available Virtual Memory 7.26 GB
Page File Space 2.38 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled
Device Encryption Support Elevation Required to View
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

Despite System Info saying windows version 18363, my Windows screen shows 1909.
Wierd.

Do you have access to an ANT+ dongle? It could be an issue with connecting using Bluetooth.

Hi Paul,

I don’t have ANT+ dongle, but did try using Companion as a BT receiver, which then transmits to Game over wifi.

Also connects 100%, but the software hangs as described regardless of how I connect to devices.

Must be a clash somewhere on my laptop/system with Zwift.

Once lockdown over, maybe I’ll borrow ANT+ to see if by some fluke this resolves it, but I don’t think it is a device connection issue.

Regards,

Craig Boswell

1 Like

Has there been a solution for this?
I have a dell xps 13 9360 as well and mine is not responding when starting zwift or joining a map.
Happens with both, bluetooth enabled or disabled.
I already reinstalled zwift and updated all my drivers as per zwift support.
Best,
Jonas

Hi Jonas,
I never resolved this on my XPS. I believe the integrated graphics card/driver is the issue. There are upgraded drivers available, but not via approved Dell channels. I resorted to using Zwift on an older Dell laptop which worked fine, albeit with slow loading times. Ideally Zwift needs to be on a gaming laptop which has the hardware for this “game”.
PS: I do not believe the issue is around BT, but I can say it is a LOT simpler just to buy a USB-ANT+ stick. Easier and better signal.
Hope that helps.

I tried both the intel and dell drivers but none worked.
I don’t really think it is a bluetooth problem either. However, I do get a lot of whea-logger event 17 errors…