December Mission app miles don't show

Anyone used the iOS app for the December mission. I used it yesterday but my miles do not show up for the 26.2 mil challenge.

I’m android but mine didn’t show either

Do u have to sign up for it or is that automatically?

i’m not getting this - it runs 2nd Dec to 31 Dec - so far i’ve ridden, in this time frame, 264 kms - (164mls), yet i’m credited with 102.6 - even if you take the from date of registration i’ve ridden 162kms

yeah I registered on my MacBook for my cycling part and that worked fine. I then opened my iPad for the run and it didn’t give me the option to register. so I returned to the Mac, selected run and it gave me the option to register but on returning to the iPad, it wasn’t there again? im assuming an iOS bug that needs fixing asap.

I am a runner, but I guess it is the same bug that we get. I got it on Kona and for the November mission too. About only 50% counted, so I started to make a rule of no run of more than 30 minutes so it didn’t feel so bad when it didn’t count. The only way around it I found was to re-calibrate before each run. That worked for me four times in a row to finish off November. Fairly easy but a pain remembering before a run. I don’t know if this helps or will work for cycling.

Where do u register? Can’t find it on my apple tv…?

You need to be on the latest version of the app on the apple TV, I am not sure if the Desember update is available yet.

I registered on my Mac app… the iOS and tvOS apps haven’t been updated yet so you can’t register on them.
not only that, despite being registered on my Mac, the run I did on my iPad today didn’t register the km to the challenge.
really frustrating… they say an iOS update is coming in the next few days but we’re already over a week into December… which is going to make it hard to fit the distance in unless they get the apps updated asap!

This is from @Seth_Steen at Zwift, it should also apply to the Marathon running mission:

Same here! My cycling kilometres are absolutely fine but my running ones don’t show up. I emailed support and they know about the issue. They say that they will manually credit the distance from my running activities against the mission. I doubt it but these are the two replies I got:

1st reply:

Thanks for getting in contact with us, and I’m sorry to hear about the trouble.

We have received a number of similar reports from other members missing mission progress. While I’m sorry for any inconvenience or frustration this may have caused, we’re still currently looking into this issue and don’t have any workarounds or a fix available at this time.

If you finish the required amount of time in Zwift without the time that’s currently missing, great! If not, and you would have with the inclusion of the missing time, please let us know after the mission ends, and we’ll be happy to have the kit added to your account.

If you have any further questions or concerns, don’t hesitate to email back.

Ride On!

2nd reply:

Thanks for reaching out again.

I’m sorry for all the trouble, but I’m happy to help.

We won’t be able to visibly update your in-game New Balance Mission progress indicators due to technical limitations. We can, however, internally track your progress.

As long as you complete all required races and any necessary requirements before the mission expires, we can ensure that you’re given credit for any missing distance that was associated with this mission for completing it.

My best advice is that you keep riding or running in Zwift. If you still haven’t completed the mission by the time it expires on December 31st, let us know at the end of the month; we can take action after the mission is over. We’ll total up your progress on our site in an effort to properly reward you for your efforts.

Thanks for your continued patience and understanding while we improve Zwift. If there’s anything else we can help you with, please let us know.

Ride On!

1 Like

Last iOS update fixed it for me

Im struggling to figure out how to signup.

I normally use ZWIFT on an iPad. After being confused on the sign up process for a few days I finally read the fine print which say you can’t sign up on an iOS device but you can accumulate miles. So I downloaded swift onto my MacBook. I’m not connected to the trainer and don’t see how to sign up on the mac book either. I see the logo referencing the challenge on the screen to start the ride but don’t know what to do, clicking it has no effect. Do I sign up there or at the screen with the garage and other stats? Do I have to be connected to a trainer to sign up?


It should be on your start screen

Do the kilometres ridden have to be done in London? The London clock tower makes me wonder… I also didn’t get it after 2 rides.

No you can ride it in any world.

I also got the email today.
Finished a few days ago :smiley:

1 Like