December 14th 2020 - ERG mode stopped working, 2 trainers

I was doing a custom workout, and started fine, but after a quick stop to get more water, I hopped back on, and ERG mode was not working. I usually have a few seconds before ERG mode kicks back in, but this time, nothing. I even tried to get the wattage up to the range, and nope. I had a 245 watt interval coming up, and did not want to try to do that without ERG working, so I cancelled out, and tried again. No erg mode from the start. So I power cycled the bike, and rebooted the computer. Logged back in, and no ERG. I shut everything down, and brought everything back up, and still no ERG.

I swapped trainers, and STILL no ERG on the second trainer. Weird…

I switched to TR, and ERG was fine. I have been getting a lot of ‘Bluetooth serial failures’ too with the Kickr trainer I have. I had a whole screen this time, getting 2 in what seemed like every second. The second trainer did not generate those messages (Neo 2).

So, I think I did everything I could do, except uninstalling the app, and reinstalling it.

What’s going on? I mean from the start ERG mode has always grabbed the trainer and off we go, but not today. Can anyone help?

AND I can’t post the picture of all of the failures. GRRR…

Is there a key that turns off ERG mode? Wouldn’t it turn back on after a restart?

What would turn off ERG mode like this? I used to just hop on, select a workout, and go. Surprised ERG isn’t working.

There IS!

If you hit the up arrow key, you get to a menu that I wasn’t aware of, and it has a setting for ‘ERG Mode’, either on, or off.

So, even though someone starts a ‘workout’, which basically requires ERG mode, you get no notice that you can’t do that mode, and it’s turned off.

MAJOR UI FAILURE! And how the ■■■■ that got turned to ‘OFF’ is beyond me! I didn’t go through that menu process to eliminate the possibility to make ERG mode work.

Stupid. There has to be more than one way to turn this off. I don’t remember turning ERG mode off. And why the heck would it be possible to turn ERG mode off in the first place, and since it’s possible to kill it, why the heck doesn’t the damn app tell the user ERG mode has been disabled, and is impossible?

Please, Strava, FIX THIS! I spent a lot of time swapping trainers, and communicating with people to figure out what the heck went wrong. Either eliminate the way to turn it off, or WARN THE USER it’s been ‘turned off’.

Please…