ERG mode option


(Kris DWTX7) #1

  In the workout screen the option to enable or disable erg mode is  gone.

I have a tacx neo and the problem is since a few days now.

Controllable trainer is selected but erg mode is still not showing.

Tried to reinstall doesn’t help.

Any idea , or another way to turn it on or off?


(Cleve Waterman 69y/o) #2

Same here.  No ERG.  Single ANT+ dongle.  FE-C for power and controllable trainer.  Power cycled the computer (Win 10) and the Wahoo SNAP (1st gen).  Nothing else that could have captured the controllable trainer.  iPhone is not on. Trainer Road is uninstalled. 


(Cleve Waterman 69y/o) #3

I notice the following in my prefs.xml file:

-<WORKOUTS>

<USE_ERG>0</USE_ERG>

</WORKOUTS>

</ZWIFT>

 

I had been using the World Tag, but I removed that recently.


(Steven D) #4

Hi Kris,

We’ve discovered a game bug that removed the option to select ERG mode from the Workout menu on all computers (PC and Mac) used as a platform for Zwift. Sorry about that!

We’re not collecting any additional information on the bug at this time, but we expect to have a fix in the next game update, which we’re aiming to send out very soon.

The good news is that ERG mode still works and I’ve personally tested it to confirm that fact. If you have a smart trainer paired to the game when you start a workout, ERG mode should automatically be turned on by default.

If for any reason you feel that ERG mode is not turned on, you can toggle ERG mode on or off from the Zwift action bar during your rides, or from the Zwift Companion app.

I’ve included screenshots displaying where you can find the ERG mode buttons on both the Zwift Companion and the action bar in-game on your computer.

Action Bar:

Zwift Companion:


If for any reason you feel that ERG mode is still not working even after your attempts to toggle it on as described above,please submit a support ticket and one of our Zwift support colleagues will be happy to assist you.

 


(Vincent W.) #5

Hey all, this bug has been brought to the dev team’s attention and should be fixed in a future update. Thanks for keeping us posted! 


(Andrew Patterson) #6

Neither of those two options to enable ERG mode are on the app or in game. 

Using the ERG mode is the primary reason I went with Zwift over your competitors. I hope this is fixed very soon, or you will be losing me as a customer. 


(Steven D) #7

Hi Andrew,

I can see you’ve got a support ticket open for this issue, which is good to know.

I had a look at your activity in Zwift using the tools at my disposal and I can see that you have not paired your KICKR as a Controllable Trainer. That’s the reason why you are not seeing the option to enableERG mode

For instructions on pairing your KICKR to the game, please refer to our Zwift KB article for Pairing your devices with Bluetooth (BLE).

Thanks!