Damaged driver adapter

I’ve just received the Zwift hub, my bike got a quick release so normally I chose the pink adapter with 130 mm. But when I try put the quick release skewer through, it’s seems like there thread on the other adapter, the one that comes pre installed (the drive train side). So the skewer just won’t go through. In the video about mounting the bike, the presenter just put skewer through with no hassle.

Best regards

Contact support and they’ll probably send you a replacement if it’s faulty

The adapter is threaded? That’s really strange. Are you sure it’s not just badly machined? Like there’s a small ridge of metal in there or something? Given that the inside is not supposed to have threads, I don’t know how the inside would get accidentally threaded :slight_smile:

Have you tried gently tapping the skewer through the adapter with a rubber mallet or something similar? If there’s just some poor machining going in, that could do the trick. Don’t hit the skewer too hard, they can bend. Fair play if you don’t want to go hammering things. But that would be what I’d try first, just to avoid the hassle of contacting the company for a replacement.

Personally I would drill it out to whatever size the skewer is. That would be a sure fix in a couple minute.

I’d do that too if the mallet didn’t work, but I don’t want to necessarily recommend that to a stranger who may not have the right tools or confidence. And might then yell at me if it doesn’t work and voids his warranty or something :smiley:

But when I first started working at the shop, I was surprised at how often hammers get used to fix bikes.

There are multiple reports of this manufacturing defect on the Zwift Facebook groups

Interesting. Not being on FB to check–is it really that the inside is threaded, or that there’s a milling/casting defect in there?

I’m experiencing this as well. It doesn’t look like it’s threaded, just not wide enough to get the skewer through. If I try inserting the skewer the wrong way through the adapter, it goes in partially, but not all the way. Almost like the hole is not fully drilled out to the right diameter. I don’t really have the tools to try drilling it out myself so I’m stuck waiting to hear from support (on a rainy day when I could be Zwifting right now!) @Mathias_Kristiansen were you ever able to get this resolved?

Tryin today to install new Zwift Hub One I got 2 day ago and exactly same issues. I’m looking fror answer from Zwift support🙏

I have a problem with my new Hub too. Here it’s the thru axle adapter on the cassette that don’t fit because of a poor quality inside the adapter. So annoying that there’s no possibility to talk to someone at Zwift, my email request took three days (different time zones?) and after 5 days the new parts are stuck at UPS.

We have the exact same problem. Support couldn’t help yet, requested some videos but could not even open a simple YouTube link. We’re a bit disappointed, I mean, they should already know the problem as we are not the first ones.

youtube. com/shorts/rX9qnQn7f4M?si=25hq3lTolFek5Rm0

youtube. com/shorts/-NjzxyOwCH8?si=AbjhGlgVg3tbv3zw

1 Like

My first Zwift Hub has a resistance issue and Zwift sent a replacement hub. I couldn’t get the skewer through the second hub because of what appears to be a defect in the “Zwift hub axle adapter”. This is basically a 5 cents part. I swapped the axle adapter from the old hub with the new hub, problem solved. This is something Zwift support could drop in a small envelope and send in the mail.