Custom workouts category missing [SOLVED]


Just logged in and wanted to edit one of my custom workouts before training, but the “Custom” category is not where it used to be. How do I edit my workouts?


Hi @Jacob_Michaelsen

I had the same this morning, found the custom workouts way down the list. I don’t know why it moved.

1 Like

That’s weird - i’ll check mine later

workouts is an area in much need of improving.

Hi @Gerrie_Delport_ODZ

Thank you, I’ve found it. I missed it or maybe restarting Zwift helped, anyway it works now :slight_smile:


Agree @Chris_Holton, I only use custom workouts for my training. Going directly to editing a workout is a bit difficult IMO.

Hey guys,
Logged onto Zwift yesterday only to find that all my custom workouts had vanished including the workouts drop down folder… any ideas what’s happened or what I need to do??

Hi @Chris_Everard

See the solution above. Let me know if you see something different.

Select Custom and then click on any workout to get the workout table.

Custom workouts moved down the list.

Yeah, my custom folder was way down the bottom of the list for no apparent reason. had to scroll right to the bottom.

the best way to access your custom workouts is to just select any random workout and navigate to the folder as you did before. The new UI does not work for workouts.

1 Like

The way I ride Zwift has been destroyed.

What’s with the war on Custom Workouts?

Now the Custom Workout tab is completely gone! I USED to edit workouts and ride them almost everyday. That has ended. Prior to this last update, if I tried to delete an update, it selected it for riding right then which was crazy, but now it’s gotten even worse.

Am I the only member that did their own custom workouts? Am I the only member thinking of quitting now that they can’t have that flexibility we had before?

I don’t ‘free ride’, I like to sweat and push myself which is why I created so many custom workouts, and now it’s all gone. PLUS I have to use the new UI to select workout rides. I don’t want to select rides, I want to be able to EDIT rides. I would really like to have more control over the rides I have created.

And the create a ride is something not created by a programmer, right? In all my years as a programmer, I rarely created a program from scratch. I would take an existing program, sometimes many existing programs and knit them into a new program, writing new code to pull it all off, so taking a custom ride and making it bigger, harder, softer, shorter was so incredible. It was a feature that the competition forbids (currently). I can’t tailor a TrainerRoad workout for what I want to accomplish. It’s all baked and ready to serve. Some days I want to punish myself on a ride, other times I want to take it easy. That ability is gone.

The one thing that I felt gave Zwift an advantage over TrainerRoad is GONE!! I urge you to rethink this massive change. Bring back more rider power over custom workouts!! Stop making the UI so ‘easy’, make it usable. Make Zwift different from TrainerRoad.


What platform are you using? I use an iPad or Apple TV and have no issues with using, or editing, the custom workouts I have created.

Mac Mini, Monterey.

Prior to this latest update, I could still edit workouts, but it was in the confines of the new UI design, and several times I would edit a ride and then choose the ride and the changes would not be in it. Like the ride edits weren’t written to the ride at all. It didn’t seem to make much sense at the time, but most rides worked fine.

It seems to, prior to this update, to select a ride off the new brain dead UI, and then have access to the ‘old UI’ and have parts of it missing was disturbing, and now it’s mostly gone. It’s unfortunate that there has been such a dramatic change.

Perhaps the iPad UI retains the capabilities that I see are missing. I wonder if it’s an oversight, and they will be excised in their next update.

Any chance you might still be logged in to Zwift on another device?


Did you see my post above. Were you able to find the old custom screen?

No, not possible.

I will look for it.

I looked for it yesterday, and didn’t find it.

BUT Did they fix the Delete function? I tried to delete a ride, and instead it was selected to ride right then. No delete unless I actually tracked down the physical file, deleted it, and restated the app. Not ideal, and could that make the app unstable? Programs often don’t like it when people move the cheese on them.

I had this a while ago:

but it seemed to fix itself for me. I’ll try deleting one again today in case it has come back again.

sorry for the dodgy video

if you watch to the end i think it does what you are describing

1 Like

Just logged in to find that all of my custom workouts have disappeared (Windows user). Despite the ‘Documents\Zwift\Workouts\xxxxxxx’ folder being populated with all of my ZWO files, nothing is pulled through to the application. I’ve tried renaming and re-generating the folder at logon; all workouts are rebuilt from synchronization with my Zwift account, but still don’t pull through. I’ve even verified the integrity of the ‘workouts.files’ file and syntax, everything appears to be fine but still nothing shows.

This is an absolute disaster for me as I only use custom workouts (1,598 of them to be precise) for my training. For as long as I can remember Zwift has handled this immaculately, even allowing subcategorisation; but something significant has clearly changed with the handling of custom workouts. This is a big one for me so I’ll be forced to take the leap over to TrainerRoad if it’s not adequately resolved. Anyone come up with a suitable workaround?

1 Like

Hi @Matt_Breakwell2682

welcome to the forum,

Did you read a few posts above. They moved.

do you make a new one every time?

1 Like