Custom Workout does not always allow or respond to adding cadence to blocks

I’m struggling to get each individual portion of a custom workout to have a unique cadence added. When I drop the cadence icon on top of each of the training blocks, it only sometimes comes up with the field to enter the cadence. In some cases it does not do anything. In others, I have to do this repeatedly to get it to work.
Often I just have to start a new block entirely and build the other parameters again.

Hi @Michael_Suppa

Thanks for sharing your concerns, and I get how that can be frustrating.

Are you building the custom workouts from Zwift on a computer or are you using a mobile device like an iPad for example?

From a desktop computer. Windows with keyboard and mouse.

Understood, @Michael_Suppa and thanks for that info!

You did a good job articulating your issue, Michael. However, based on what you’ve explained it’s the type of issue where a video would be extremely helpful.

If you could record a short video showing your exact process when attempting to add cadence targets to various training blocks, this will presumably illustrate your issue more clearly.

My thought process is that a video will enable us to better advise you or provide us with evidence of a problem if we need to flag it up as a possible bug or functionality issue.

You should be able to either hyperlink or upload a video here on the forums. Or, feel free to send us an official support request, include the video, a description of your issue, and we’ll take it from there. You can contact us here.

I did an arbitrary workout and showed how cadence is finicky. Expand this out to a longer workout with many blocks and many different cadence targets and it gets super annoying to the point of giving up entirely.

it is very difficult to upload a video here. you can’t send the link; the forum blocks it so i had to truncate the https portion. and only image files are uploadable in the reply box. either way the link above should work copy/pasted.

have you tried :sunglasses:

did not know that existed. thanks for the post. might be a solution. still doesn’t resolve the core issue though and zwift should be working on adding these to the backlog and work on it in their sprints (assuming it is a legitimate issue and not just me).

1 Like

I agree just helping out while Zwift fix it.

Here is another one.

You can also edit the .wko files in notepad. :sunglasses:

1 Like

Thanks for sending these. They’re definitely helpful if I don’t want to go all the way into a the game just to make the workout.
I’m learning there is far more third party/community based websites, apps, and add-ons than I imagined.


The video you provided, @Michael_Suppa perfectly illustrates the issue, and I found it extremely helpful. Thanks so very much for providing that.

You’ll be happy to know I’ve flagged up the issue to a higher technical authority on the team, and I’m waiting to hear back from them. I’ll update you when I have more information.

Otherwise, the third-party resources shared by Gerrie are an excellent suggestion, and thank you for sharing that @Gerrie_Delport_ODZ !

1 Like

Hi @Michael_Suppa

Just wanted to check in and let you know that I received word from the team that your issue has been reproduced, we’ve bug reported it, and we’re working on a fix. Thanks again for reporting this!