Current Issues with Elite Direto Trainers


(Nico) #21

Btw, I also get about 20W difference with my power2max (Elite is lower).

@Hans_Andersen_DBR - do you use the Quarq for power and do you use ANT+ or BT?

In my case, I have used ANT+ and BT and always connect to FE-C (except when I connected to BT, then it has a different name).


(Gaetano) #22

@Ethan_Shin if you read carefully the manual, it’s reported to use the 175 as circumference only if you source the speed from the Speed&CAdence service. That’s not the case of Zwift.
the value to use is the exact circumference of your wheel.
Using 175mm as wheel circumference leads to a very low resistance.


(Ethan) #23

AHH… I never read manual carefully… haha Thanks for the input!

Now I’m wondering about my 3~4 rides when I had no problem with resistance even when the circumference was set to 175…

Anyways its working fine for now!


(Chris) #24

Resistance went really well today and only one complete data drop. I’m counting it as a win. Ha


(Carlos) #25

Got a Direto this month. Essentially random whether resistance changes or not on a ride. A couple of rides it worked, but for most rides it didn’t. I always make sure to connect via Fe-C. Plus there’s a heck of a lag.

ERG mode is very wishy-washy - simply never reaches the target but floats 5-10% below unless I spin up to 110 rpm, then it will fall back down if I go back to 90 rpm. I generally ride in the 85-95 rpm range and typical gearing is 52-19.

I’ve tested ERG mode on golden cheetah and Rouvy and it doesn’t have this problem. Something in Zwift is causing it.

I’ve ridden ZWIFT extensively with a Magnus and it didn’t have these problems.

btw, using ANT+ with Windows 10. Always select FE-C. Usually take power from powertap chainring output but sometimes ride with Direto power output.


(Nico) #26

@Ethan_Shin: I’ll try changing the circumference and will report back if it made a difference.

It would be nice if Zwift or Elite would make a bit of an effort to help us resolve this. It feels a lot like we are just left to our own devices…


(Ethan) #27

I feel you… I’ve heard bad stories about Elite’s service response, but it wasn’t as bad as I expected. How did you contact Elite? I submitted my email through the My Elite app and they got back to me within 3 days. Zwift was more like a copy and pasted response…


(Nico) #28

I have had a few responses from Elite, but mostly not enlightening.

Zwift escalated my questions by two levels, in the end I got referred to this thread, that’s about it. Not an unpleasant interaction with the Zwift staff, but again no useful information or ways to resolve.


(Dave) #29

Folks… he asked us to “please submit a support inquiry”… not to post a reply!!!

Submit a Support Inquiry if you want to get these issues resolved… and be sure to reference a link to this Forum topic in the Support ticket!!!


(fabrizio) #30

I do a support inquiry now,and I reference this link,ihope solve this issues…


(Nico) #31

@Dave_Severn_FL_Cat_C: I have been through endless communications with support, up to level 3, who were all unable to help. They finally referred me here.

Update: I tried tonight to set the wheel circumference to 2076. However, it doesn’t shop as such in MyETraining: the app (both on Android and on Windows) keeps showing 173. I also didn’t get any improvements in the behavior of the trainer with Zwift. Still have to use Zwift without connecting the trainer and setting it to constant resistance using my Wahoo Elemnt, which works.


(fabrizio) #32

On elite direto review https://www.dcrainmaker.com/2017/09/elite-direto-trainer-in-depth-review.html , DCrainmaker on comments section write .“Zwift doesn’t implement ERG mode in the same manner that almost every app does. Most apps implement ERG mode in a strict sense: App tells trainer to hold 350w, and trainer holds 350w, almost spot-on”.


(K) #33

I’m not sure if this helps the Elite Zwifters using Ant+, but I don’t recall having any issues by pairing the Direto as an Elite Real Trainer (can’t recall the exact choice name) for Power and Cadence and an Elite FE-C Trainer as the Controllable Trainer. They might try this pairing setup.

I don’t recall updating the firmware on my Direto except when I bought it in September 2017, but sometime since last summer there has been a tendency for Zwift to automatically pairing the Controllable Trainer as an Elite Real Trainer and I often have to re-pair it as the FE-C Trainer; otherwise, I’ve had similar problems described in this thread.


(Nico) #34

How did you update the firmware on your Direto? I had a look aroudn and couldn’t find any info on firmware updates.


(K) #35

I think it’s done with the Elite phone apps which you can download through the Apple Store or Google Play sites.


(Anthony Doud) #36

I use Zwift on Win 10 in the house and game stream it to a Nvidia Shield TV in my pain cave. Sensors all connect via the iPhone Zwift companion app.

I ride almost daily and other than an occasional companion app drop (once per month maybe), I haven’t had any issues with the direto. I have power smoothing set to 6 via the Elite app and only do a spin down occasionally. Make sure you force close the Elite app when you’re done and pull the power plug on the Direto for 30 seconds before you connect back to Zwift.

I have had issues with it in the past on Sufferfest when doing steady 300 ish watt efforts - resistance fluctuations every few seconds, like its hunting for the proper resistance. What mostly solved that issue was using a lower gear so the hub spins slower (little ring front, 20t on the back). It seems the way the direto firmware is setup it just doesn’t do well at high hub speeds.

Ride on!


(Matt) #37

I just had this happen mid-ride do you know what the fix is?


(FRANCESCO) #38

Hi there, here another one with that boring issue,
i’m Direto’s owner by 4 days, before and after calibrating it with the Elite’s app, the Direto 2019 is even with the power too much floating! I went form an Elite Rampa (with a power estimate) calibrated with a Stages Power Meter and it was really spot-on with Zwift, absolute stable!! I made the upgrade to Direto 2019 only because i got a problem in dicember to the Rampa’s electronic mother board.
So, how to solve that bug?? With Elite MyTraining it’s ALL Ok! The bug is only with Zwift! I can’t complete a serious workout at moment, i tried other solutions like to use a shorter usb cable, but that’s not the point unfortunately.


(FRANCESCO) #39

Which is the last Direto’s firmware?


(Anthony Doud) #40

I don’t think they’ve ever released one.