Critical zwift bug, crashing my computer

Zwift is crashing my computer every single time i run it.
It simply crashes it, and the only log or information available anywhere is a kernel power error.

zwift is the only piece of software doing this, and i run a lot of WAY more demanding programs.

Anyone else experiencing this?
Or do anyone have some good tips on how to look for a more detailed explanation?
It crashes my computer all the way out to the bios, but it crashes so hard that it doesn’t even turn on the cpu-fans until i do a power off.
i can’t keep using a software that may end up corrupting data on my drives bechause of stuff like this.

here are my specs:

Asus x470-f motherboard
Ryzen 2600 (with noctua nh-d15)
16GB corsair lpx 3200mhz
palit 2070 super
samsung 3840*1080p monitor (don’t remember model number)
Windows 20h2 build 19042.1083
nvidia drivers: 457.30

zwift version= what ever version publicly available as of writing this.

That doesn’t sound like a Zwift issue, other than to say it stresses components a lot harder than you may expect and draws out any instability. Do you have any overclocks on your CPU, RAM or GPU? Take those off to start with, and test. With an X470 board I assume you’ve overclocked your 2600, so I’d guess at that being the issue. What PSU do you have?

I see i made a typo, it’s a ryzen 3600.
I doubt that it’s my overclock, as i can run prime 95 all night without crashes, and i can run furmark for as long as i want.
Memtest has not yielded any results either, so my only conclusion is that zwift has some sort of intermittent memory leak or something…
But i don’t know.
My system is kept below 60c with the cooling i have and no other apps actually crash my system.

I had a feeling you’d say this, it’s exactly the kind of thing that doesn’t matter when it comes to Zwift, believe me. :rofl:

I’ve had overclocks run for hours in Prime 95, OCCT and AIDA64, and then load Zwift and have the system crash in minutes.

Furmark is exactly the same btw, but that would usually just see the game disappear and/or the driver crash. The whole system going down I would expect is the overclock on the CPU.

I see, well the OC is within the stated operating clocks stated by amd, only it’s set to all core.
I’ve never had stabillity issues with anything else, even heavily modded minecraft consuming 8GB of ram with 30 fps max due to cpu-load has yet to crash the system.

I will investigate further.

As I said, unfortunately you can’t rely on Zwift to be stable even if every other application is. I’d definitely give it a go at stock clocks before doing anything else. See if the problem is resolved, before checking out if there’s a tweak to the voltage or OC which fixes it.

FWIW I’m running an overclocked 2300X at 4.10GHz all core on a B350 board with no issues. But from me and others playing about with all sorts of CPUs, I can tell you that Zwift can bring about a spike that causes a crash on an OC that passes every trusted stress testing tool you can think of.

I think you were correct Dave, i did a fresh install of windows with only zwift and redid the OC, turns out my asus mobo gave my ryzen 3600 1.47V.
I lowered it to 1.38 and upped the OC to 4.1 all core, temps are much lower and the system is super stable.
tried starting and closing zwift workouts many times without anay issues.

I guess stabillity issues shows itself in many ways and i will use zwift as a benchmark for stabillity in the future :smiley: