Crashes with AMD Radeon graphics [MERGED] [SOLVED]

Hi , with the latest zwift update in april this graphic card has become support for the ultra-profile.
The graphic now looks very nice, but i noticed that now the world “Innsbruck” crashes after a few kilometers (mostly after 2,1 - 2,4 km) on my windows 10 pc.
On other worlds i’ve noticed that problems not so far.

Latest AMD drivers (21.4.1) are installed.
The zwift log says nothing except that it crashed.
the windows eventlog tells more:
Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Zwift\ZwiftApp.exe
Pfad des fehlerhaften Moduls: C:\Windows\System32\DriverStore\FileRepository\u0366490.inf_amd64_c0dea8a43cb81731\B366217\atio6axx.dll

Are there more people with this bug?

best regards

Hi there. Did you update the launcher as part of the April game update? Right-click on the Zwift icon in the system tray and report back what version it says. I expect it will be 1.0.52, in which case it may be worth trying a previous launcher version and seeing if the problems go away.

Hi Dave, yes, i’ve got the new launcher. I do an complete reinstall of zwift with the april-release. But what should fix an old launcher if the mainapp crashes because of errors with the graphic cards driver? The launcher is only to split the login/account-stuff from the mainapp i think.

Ha, yeah. That’s what’s meant to happen, but I can prove otherwise.

Anyway, check your PMs.

Yup same problem as on the RX 6700 XT. Just crashes to desktop now after 10-30 mins. Might be latest graphics drivers for the RX 6000 series, or the latest Zwift update. Same error as above - zwiftapp.exe stopped working, then atio6axx.dll as module that failed.

@xflintx any ideas?

It’s a bit of a joke really. I have been paying for a zwift subscription for about a year. In that time it has crashed on every single device, become unusable on Surface Pro due to crashes, now it crashes on a £2500 new PC. Every time one issue is solved the next update brings another problem. Really at the end of my tether with it. Ruins all the team events as I am constantly letting people down with crashes. Where do I request a refund?

1 Like

With the latest update the crashes to desktop bug switched from the Innsbruck track to Watopia (and i don’t know where else) The crash happened now always at the same point on the Mountain 8 track (after 2.8 km). For me Zwift it is on my stable running pc hardware not usable anymore, i canceled my subscription.

best regards

That’s a real shame. Crashing at the same spot suggests there’s an asset or similar which suddenly creates an unusual spike in load on the GPU, so the driver shits itself and the game dies. If it’s repeatable then there’s no reason why they can’t resolve it.

it took me a long time in communicating this bug to the support. they have all detailed windows eventlogs and because this bug is always at the same point it is exactly how you say, it is repeatable and this should be no rocket science to find and to fix it.
but i think zwift’s main focus is to apple tv / tablets. that is how most people are using this application.
still disappointing for pc users.

1 Like

Totally agree. They’d probably prefer you to buy an Apple TV.

I rolled back the AMD driver to previous and it seems to have stabilized for now. I’m sure it will crash during the last playoff tonight (joy)

1 Like

The best thing I can recommend right now to you and everyone else that’s getting this crash would be to follow the steps in this article.

When you get the file, you don’t need to send it into support, just look over the logs yourself. We are looking for error codes related to Zwift.

To find them, click in the top half of the window with all the events, and then CTRL + F and search for Zwift. Go through the lines slowly and look for the information as to why it’s crashing.

Usually, we see one of two error codes:

  • 0xc0000005
  • 0xc0000347 (I think I have the numbers wrong here, but it has a 3 and a 4 in it)

The first one indicates a variety of issues, but is usually related to permissions or loose hardware. The second one indicates a heap corruption and is usually related to drivers or failing GPU.

Basically, finding these codes will help us narrow it down and determine that if it’s specific to this card, we can look more specifically.

Another good rule of thumb on these is to just revert back to drivers that didn’t give you the crash. I do this all the time with my Nvidia cards, and you’re all likely familiar with this method.

at my pc it’s always this error:

Ausnahmecode: 0xc0000005
Fehleroffset: 0x0000000000025bb6
ID des fehlerhaften Prozesses: 0x2450

i’ve sent the crash report based on your manual to the zwift support.
the gpu is only at ~ 50% workload, the cpu < 10% in zwift.
at 1080p with ultra settings this amd card had not really much to do.

At 1080p you’ll be CPU limited with that GPU. Not that it’ll show up in the CPU utilisation numbers, Zwift doesn’t work that way.

Based on this, it’s probably not necessarily related to the GPU, but could be permissions issues (i.e., accessing files during certain parts of interacting with Zwift) and/or failing, loose, or faulty hardware. It could also be related to RAM, based on the articles I’ve come across in my time seeing these.

I have a RX 5700 XT and the same issue. All new AMD GPUs seem to have problems. Zwift admits a fault:

I am having the same issue. 6800XT

I’ve tried 4 different AMD driver versions and all are crashing.

If i uninstall all AMD software the game runs fine.

One thing I have noticed - when loading into the route Sand and Sequoias Zwift will crash immediately. If riding around the volcano then it won’t crash.

Hi Cosmos. I just struggled with the same issue (freeze on Sand and Sequoias/Tempus Fugit/Dust in the Wind lead-in). I have a 5600xt.

For me, the solution was to roll back my AMD drivers to 20.8.2. Unfortunately, I’m not sure whether these drivers will work with a 6800XT. I haven’t tried any newer drivers yet but might work through them to see if any of them work. It won’t let me include the link, but my post is on the front page here in bugs describing the freezing when loading Tempus Fugit (same starting point for Sand and Sequoias).

Thanks Alex. I did see you were battling with the same issue.

Unfortunately 20.8.2 is not compatible with Windows 11 which I’m currently on.

Are you on Windows 10 or 11? Tempted to give it a go hopefully it works.

I’m on Windows 10. Sorry to hear about the compatibility issues with 11. I suspect there may be another younger driver out there that works, but I need to test some more.

Hey all,
I am encountering an odd bug I cannot figure out. When on ocean boulevard, with the ocean to your right my Zwift crashes just as you start going up the incline. I am able to ride in london without any issue, and I am able to ride in Watopia going the other direction. However for some reason, if I am going in the reverse direction it crashes at that spot.

I am going to try an uninstall then reinstall, but has anyone else encountered this?