Crashes with AMD Radeon graphics [MERGED] [SOLVED]

I uninstalled and reinstalled. Crashed in the exact same spot.

I have attached a photo of where this occurs. I removed names for obvious reasons but it happens right here. I can replicate this issue upon request. It happens in both spectator mode and in ride mode. It happens with pace partners, in private meetups, or just on regular old rides.

What device are you using.

Did you put your log file in to check your framerate FPS?

The only thing I can think of is that that is where a lot of new riders spawn and so it might struggle to keep up with rendering them all. Not sure why it wouldn’t happen the other direction though.

Are you using an old or under powered pc or android phone/tablet?

New stuff to me but I certainly can!
Per that amazing website you’ve shared with me:
FPS: Min 33, Avg 86, Max 157
Windows 10
Ryzen 5 4600H cpu
AMD Radeon RX 5600M GPU
8gb ram
256gb SSD

I am going to replicate this a few more times to see if I can see a similar thing in these logs leading into the crash

1 Like

Both of these logs are from when i was in spectator mode

NETCLIENT:[INFO] UDP metrics {StC Rx: 264, Rx error: 0, CtS Tx: 24, Tx error: 0}

This comes up consistently in each log right near the crash

Example from another log
[18:53:38] NETCLIENT:[INFO] Sending telemetry…

[18:53:38] NETCLIENT:[INFO] UDP metrics {StC Rx: 1001, Rx error: 0, CtS Tx: 59, Tx error: 0}

A wider cutout:
[18:53:26] HUD_Notify: E.Oliver - CRYO-GEN/RO4H says Ride On!

[18:53:26] Got Notable Moment: RIDE ON!

[18:53:29] NETWORK:Unhandled world message type 200

[18:53:31] NETCLIENT:[WARN] Auxiliary Controller failed to shut down tcp socket: ‘A request to send or receive data was disallowed because the socket is not connected and (when sending on a datagram socket using a sendto call) no address was supplied.’ (10057)

[18:53:31] NETCLIENT:[INFO] Auxiliary Controller failed to connect to socket: ‘The I/O operation has been aborted because of either a thread exit or an application request.’ (995)

[18:53:32] FPS 48.70, 68210, 10155, -46269

[18:53:33] NETWORK:Unhandled world message type 200

[18:53:36] Starting critical power curve search job (4694164) mTimeStamp = 60.08410 m_lastSearchTime = 60.08410 calculating=false

[18:53:36] NETWORK:Unhandled world message type 200

[18:53:38] NETCLIENT:[INFO] Sending telemetry…

[18:53:38] NETCLIENT:[INFO] UDP metrics {StC Rx: 1001, Rx error: 0, CtS Tx: 59, Tx error: 0}

[18:54:17] NETCLIENT:[WARN] UDP connection timeout (1 so far), reconnection attempt 1

[18:54:17] NETCLIENT:[INFO] Connecting to UDP server…

[18:54:27] NETCLIENT:[WARN] UDP connection timeout (2 so far), reconnection attempt 2

[18:54:27] NETCLIENT:[INFO] Connecting to UDP server…

[18:54:37] NETCLIENT:[WARN] UDP connection timeout (3 so far), reconnection attempt 3

[18:54:37] NETCLIENT:[INFO] Connecting to UDP server…

[18:54:38] NETCLIENT:[INFO] UDP metrics {StC Rx: 515, Rx error: 0, CtS Tx: 0, Tx error: 0}

Ensure your Radeon driver is up to date. If it already is, try rolling it back to an earlier version. Seen a few similar reports of weird stuff on newer AMD GPUs.

10/29 up date. A new driver came out for my card this morning which I downloaded, installed and restarted. Still crashing in the exact same spot. Only happening in Watopia, and only in that specific spot. I am going to try to find an older driver now.

Seeing the same error in every log just when the crash occurs
[10:49:03] NETCLIENT:[INFO] UDP metrics {StC Rx: 1046, Rx error: 0, CtS Tx: 59, Tx error: 0}

[10:49:07] NETCLIENT:[INFO] Sending telemetry…

[10:49:29] NETCLIENT:[INFO] World clock offset updated from +1835798328ms to +1835798328ms (+0ms)

[10:49:40] NETCLIENT:[WARN] UDP connection timeout (1 so far), reconnection attempt 1

[10:49:40] NETCLIENT:[INFO] Connecting to UDP server…

had also trouble right on that spot both ways with zwift crash/hung
tried several drivers. but today it worked with this driver

passed 2 times right before when riding with diesel :slightly_smiling_face:

go offline (so not windows install their driver)
uninstall your driver with ddu
display driver uninstaller will you find at guru3d:com


1 Like

Those error messages are a red herring, try the driver version mentioned above.

1 Like

10/29 afternoon update
I can confirm the driver roll back option recommended appears to be the fix for this issue.
I am not sure if it is a Zwift thing or an AMD thing but hey, it worked.
In my specific case i rolled back to a driver from July 2020. Hoping there is a fix soon as this will affect New Worlds performance:)

THanks everyone for the input!

Glad you’re sorted, but unfortunately I suspect you’ll be waiting a long time for Zwift to fix whatever the problem is. AMD graphics cards are particularly unsuited to Zwift because their Windows drivers aren’t very well optimised at all for OpenGL games. :confused:

Thank you guys all for the info! I’m wondering if this might be a more prevalent problem with the latest AMD drivers.

I’ll be keeping an eye open for any more reports of the same issue, in order to figure out if this is the sort of thing that may require an update either from us or from AMD.

1 Like

Same here, did a downgrade to Radeon-Software-Adrenalin-2020-21.10.1-Win10-Win11-64Bit-Oct5 and it seems to be working right now, but tested only for about 30min. Before that it crashed no later than 3min into the game.

1 Like

I saw a post or two on reddit of people having a similar issue.

10/31 Update: I am still on the AMD driver from August 2020. Zwift is running fine, no crashes. I have not ridden on the UCI courses but this def seems to be making watopia work properly. London runs fine on Fall 2021 AMD drivers I can assure you that.

1 Like

@Holger_Wachter when you were getting crashes, was it always at a specific place like OP or just randomly?

At first I thought it was at the same spot (it always crashed there), but yesterday I attempted Alpe de Zwift, where it also crashed after about 3minutes in (route Road to Sky). Another crash was when watching another player without the trainer being connected, then switching “back to me”. Happens with all AMD drivers starting October 5th (I have to use them because of Windows 11). I already filed a bug report with AMD, too. For now I have to use my android phone.
Game freezes and the windows error reporting tool will pop up after a while.
Event log will only show apllication hang on zwiftapp.exe with no error code, also no GPU-related entries in the event log.
In the past I had problems with Onedrive uploading the Documents folder, but I always stop sync before runnign Zwift, which stopped the problem. Seems to be Windows 11 with AMD GPUs.

1 Like

Hi! I just wanted to update anyone who may be following this topic. Over the past week, we’ve received some more reports of this issue, involving mid-ride crashes/app hangs, which seem to occur at certain locations within the game.

Here’s what we know so far:

  • Known to occur on AMD Adrenalin versions 21.10.1 , 21.10.2 , 21.10.3 , 21.10.4 , 21.11.1 , 21.11.2.
  • Some reports that 21.11.3 (optional update) resolves the issue, but not enough info to be sure if this is true across the board.
  • Windows Event Viewer log shows Application Hang (1002) but not much else.
  • Rolling back to older versions such as 21.8.2 may resolve the issue.
  • Using DDU (Display Driver Uninstaller) may be helpful in order to ensure full removal of driver before installing another, though it’s a 3rd party tool.
1 Like

If happening at high frame rates, this might well be the launcher/installer problem I’ve previously demonstrated. I suspect the same workaround will resolve it.

Some more observations: Also happens with latest Windows 11 Insider Build (22000.282), Non-WHQL-Radeon-Software-Adrenalin-2020-21.11.1-Win10-Win11-64Bit-Nov3 and ANT+.
So no BT issue. Crashed almost immediately after entering Watopia. Switched then back to Bluetooth, did a 15min ride in Yorkshire with no issues.

For me its Windows 11 with any Radeon driver released for Windows 11 and riding in Watopia when the crashed happen. Haven’t tried any other worlds beside Yorkshire, where the game seems to run fine.

Also reported the error to AMD, but no feedback yet.