Crash after update: "Unexpected Error" on Mac and reinstall didn't solve

Hi, after updating on MacOS Big Sur 11.4 Zwift now is able to login but few seconds later just crashes.

A message says: “Unexpected Error, Whooops! We hit a roadblock and something went wrong … etc etc”

I already tried to reinstall a fresh copy but nothing has changed.

Before reinstall, I removed the Application, the folder Zwift in Documents and in Library but
probably there is still some other folder to remove because after a fresh install
the app logs in without asking me for my credentials.
so, after a fresh install, Zwift try to update to 1.0.25 … and then after login it just crashes. (see image)

I saw a similar issue reported for Windows Platform at #552862 in “Known Issues”
but on my Mac things are still broken.

Never had any problem in the past but now I’m really stuck. Any idea ?

thanks

3 Likes

+1 seeing the same issue on MacOS 11.4 (Big Sur). After 7/19 update.
Rebooting the laptop and re-installing Zwift did not help.

Honestly, the entire situation is frustrating as they’re not admitting any issue publicly. status .zwift .com shows “all green” and the release blog post shows nothing either.

I already submitted a support ticket with support @ zwift . com with crash report, screen shots and logs. I did not get a support ticket # so I have no way of referring to it.

Now it’s 2 days straight so far I cannot do my scheduled workouts/plans.
I want a refund EACH DAY that I cannot access/use Zwift paid service.
Imagine if Netflix/Disney+ went down for days. You betcha there will be refunds!


Check your log for the crash message. The logs are at Documents/zwift/logs.
Mine crashes at:

[16:52:07] ASSERT: ""Accessory::ColorScheme::GetTextureHandle" && texture != INVALID_TEXTURE_HANDLE", file=/Users/julius.hipolito/Perforce/jhipolito_macbook_builds_depot/Projects/ZwiftApp/CODE/Items/Accessory.cpp, line=19
[16:53:11] NETCLIENT:[WARN] Error shutting down mDNS UDP socket [57] Socket is not connected
file=/Users/julius.hipolito/Perforce/jhipolito_macbook_builds_depot/

Looks like a Zwift developer “Julius Hipolito” commited dev code into prod? What is Zwift QA doing!
@Julius_Hipolito

4 Likes

me too

I get the same failure on Catalina.

flock failed to lock maps file: errno = 35

and

Support/Zwift/ZwiftApp failed on loadCmd /Users//Library/Application Support/Zwift/libant.dylib (loadCmd resolved to: /Users//Library/Application Support/Zwift/libant.dylib, bundleURL: (null))

1 Like

Remember to VOTE for this issue on the top left! Let’s this issue Zwift’s attention!

I’m facing the same issue. Since the update, no more Zwifting… :frowning:

1 Like

Me too; contacted zwift support, they sent me here eventually and said a fix is being worked on.

1 Like

It’s strange that they’re not publicly acknowledging the issue. I pointed them to this thread and said many others are frustrated due to their lack of response.

The response I got was:

I can’t even guess at any timelines that a fix may be completed…our development team is working towards a solution as quickly as possible.

Its concerning to hear that there is no fix timeline.
Remember, when this is all said and done, demand a REFUND for the X days of downtime!

1 Like

Same here. I had hoped that a deletion of the /Users//Library/Application Support/Zwift/ folder would do the trick but it came right back. Where’s @Julius_Hipolito?

Same here.

23:58:56] Loading WAD file ‘assets/Bikes/Wheels/Giant/SLR/PropelAdvanced.wad’ with file.
[23:59:03] ASSERT: ““Accessory::ColorScheme::GetTextureHandle” && texture != INVALID_TEXTURE_HANDLE”, :rofl: :rofl: :rofl:file=/Users/julius.hipolito/Perforce/jhipolito_macbook_builds_depot/Projects/ZwiftApp/CODE/Items/Accessory.cpp, line=19
[23:59:23] NETCLIENT:[WARN] Error shutting down mDNS UDP socket [57] Socket is not connected.

Re- install, clean installation… but nothing function.

Hi there, I’m one of the users on Win10 with the same issue. I’m still stuck with the issue.
I thought I fixed it after reinstalling Zwift because it would allow login without error but only for the first login. If I close the app and open it again, the "Whoops!.. " Unexpected Error box will resurface. :roll_eyes:

So now I gotta uninstall Zwift and do a clean installation every time if I want to use Zwift.

Same issue here, very frustrating. Priority bug fix

Hi all,

I’m a Zwift ambassador and I have found with a couple of users, if they create a new Mac user account and then install Zwift under that new user, it works. That’s a workaround rather than a fix, but it does indicate to me that it’s an issue that isn’t being removed by even the most complete uninstallation of Zwift.

Nothing to lose to try it out I guess.

Thanks.

1 Like

Just tried that workaround … a couple of ways;
i) Using my wife’s existing user account that has never been used for a Zwift installation
ii) Using a newly created account

Obviously both on the same MacBook that the original issue arose on

Neither resolved the problem

Hi,

I’ve just created a new user and installed from scratch … but same error here.

and unfortunately, it makes sense to me because Zwift app requires to be installed as an admin user, that means it requires perms all over the system (not just the user’s folder).

Moreover, in the new user account it crashes in the same manner as before and logs stop always at the same line:

“NETCLIENT:[WARN] Error shutting down mDNS UDP socket [57] Socket is not connected”
for sure this is a system feature, not user space.

However, I’m not neither sure if mDNS socket could be the reason of the problem because it’s reported in the log just as a WARN not an error.
It really seems that AFTER that line the app crashes without even logging.
It just Crashes. :frowning_face:

Could you let us know if some dev is able to reproduce the crash we have ?

Thanks.

This worked on one MacBook, so I thought I would put it out there.

The only other thought is that Zwift was uninstalled using the following process before rebooting and then creating the new account etc.

  1. Remove/Uninstall Zwift by going to the Applications folder and then deleting Zwift or dragging it to the trash.
  2. Open a terminal
    • cd ~/Library/Application\ Support/
    • delete the Zwift directory: rm -rf Zwift/
    • cd ~/Library/Preferences
    • delete the ZwiftApp.plist file: rm ZwiftApp.plist
  3. Empty the trash.
  4. Reboot.
  5. Reinstall.

Sorry it didn’t work for you guys.

thanks Kev, any help or news is really appreciated.

All a bit frustrating this isn’t it …

Anyway, I’ve downloaded RGT Cycling to have a look at it in FREE-mode and to get a session in that I might otherwise be missing :wink:

i create a account. but the problem continue

I just upgraded to MacOS 11.5 and same issue. Is anyone with a Mac actually able to zwift right now? I don’t see how this isn’t a global failure for mac users.