Crash after update: "Unexpected Error" on Mac and reinstall didn't solve

Beatifull =D

Apparently there is one person, @PhilBanks who is able to Zwift on MacOS 11.4. I’m not sure what his environment looks like.

I don’t see how this isn’t a global failure for mac users.

Indeed! It’s even more alarming that Zwift has STILL not publicly acknowledged the issue, 4 days later.
And they are refusing to provide me a partial refund because, apparently, downtime due to this issue is not considered an “an extended period of time”!

We don’t typically give refunds for issues with being able to access Zwift, such as this or a server outage, unless it happens for an extended period of time.

1 Like

Related issue: /t/zwift-client-crash-during-login-with-unexpected-error-whoops-we-hit-a-roadblock-and-something-went-wrong-solved/552862/40

I’d put a link here but it’s not allowed. But that’s from this site.

Hi,

Thanks for tagging me Kish.

Yep, I’m able to Zwift on a Mac with the most recent upgrade (haven’t tried it on my actual Mac, this is on a Macbook Pro):
MacBook Pro
2.7 GHz Quad-Core Intel Core i7
Dual Graphics Card (Intel 530 and Radeon Pro 455)
MacOS 11.4
Kickr 5 with Ant+ connection
Wifi connection - no ethernet connections
Currently using firefox as my default browser (not sure if that has anything to do with the launcher - just trying to help trouble shoot)

Word of warning to people…i use heavy graphics programmes (3D, Video etc) and for a good few months the only thing that would crash my computer was Zwift…it appears that it wasn’t Zwift, but an early warning that my logic board was on its way out…i have a new one now and all’s good. (I’m not saying this is that scenario, but letting you know in case other programmes begin to crash (Kernel crashes)…it might be that - fingers crossed it isn’t.)

:slight_smile:

Its because you are on 10.14 I suspect. My failure shown above is on 10.15.7 on a mid-2012 MacBook Pro.

I tested on my work laptop which is a high spec’d 2019 MacBook Pro but running 10.14 and it worked. I still think the zwift startup sequence was not as fast as pre-upgrade, but it did work.

On a professional side of things from Zwift, I think it is pretty disgraceful and disrespectful to their customers that you can’t even get a response from a zwift support person. You get redirected via email or bot to forum or the support landing page. Not even an official reply in this thread. Might be time to look into what other options are out there for riding.

2 Likes

Just a thought…

To those of you who are having issues, are you based in the UK?

If not, perhaps try setting up a VPN that says you’re in the UK, as that’s where I am and luckily have no issues like this. It might be there’s been a dodgy file uploaded to a particular repository and you’re getting pointed to that one…(Which looking at some of the crash reports, might have happened.)

Also seeing the same issue, have tried re-installing, removing ~/Library/Application Support/Zwift & ~/Library/Preferences/ZwiftApp.plist with no success. Have paused my membership until this is resolved.

2 Likes

This solution has just worked for a windows user via Zwift ambassador support.

I did it, In MAC. But not function

Hey everyone - we’ve been investigating this crash at HQ. It’s been a tricky one to troubleshoot because it’s not consistently reproducible. However - we think we have a viable fix for this coming in the next patch.

The logs indicate problems with case sensitive, for accessing assets file

thank you Shuji. Is there a timeline for the next patch ?

1 Like


yo tengo el mismo problema en windows esperamos una solucion pronto

Quick google:

Julius Jc Hipolito | Irvine, California, United States | Release Engineer at Zwift | Game Developer and Senior QA Engineer with 14+ years in the games …

:man_shrugging:

Yikes. :rofl:

Y que nos agreguen los dias perdido en la membresía.

1 Like

Same error here on Big Sur 11.3. I have a case sensitive file system. Full clean reinstall does not fix the issue. This must be affecting a lot of users.

[9:49:05] ASSERT: ““Accessory::ColorScheme::GetTextureHandle” && texture != INVALID_TEXTURE_HANDLE”, file=/Users/julius.hipolito/Perforce/jhipolito_macbook_builds_depot/Projects/ZwiftApp/CODE/Items/Accessory.cpp, line=19

Looks like a simple fix to me, a hard coded file path. That user directory is definitely not on my machine!

1 Like

@Orlando_Rozas @ACZ Interesting point about the case-sensitive file system.

I made my Apple root drive APFS (Case-sensitive, Encrypted). It is required because I have to work on case-sensitive files on git for work with Linux-compatible software.

The Applications dir (/System/Volumes/Data/Applications/Zwift) and the Documents dir (/System/Volumes/Data/Users/<user>/Documents/Zwift) are both on this case-sensitive filesystem (/System/Volumes/Data).

It’s possible that Zwift doesn’t know how to handle case-sensitive fs. Perhaps that’s why its “not consistently reproducible” by Zwift and why it doesn’t seem to affect all MacOS users. If the case-sensitive fs is indeed the issue, I’m willing to bet only a fraction of MacOS users have a case-senstitive fs. I do believe that Apple’s default for fs is non case-sensitive when setting up a new Mac.

@PhilBanks You’re on of the few people on MacOS 11.4 and has reported Zwift working. Do you have a case-sensitive root filesystem?


In other news, Zwift has been down for me for 7 days now and they are still refusing to refund me for these days because it’s not considered an “an extended period of time”!

1 Like

You could just create a case-sensitive encrypted APFS volume for that.

(It also boggles my mind that there are companies that have no quality policies for stuff being installed on developer work stations, tbh :man_facepalming:)

1 Like